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Using SPSS for Macintosh 

This document covers the basic features of SPSS for Macintosh. SPSS is a comprehensive, easy to learn 
statistical analysis and data management software. The Macintosh and Windows versions are basically 
identical. SPSS for Macintosh is publicly available in the Meyer Library clusters, the residence hall 
clusters, and Tresidder LAIR. To use any of the public computers on campus, you must have a SUNet 
ID (Stanford University Network Identifier). If you do not have a SUNet ID, visit the Web at 
http://www.stanford.edu/services/sunetid for information on obtaining one. 
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Getting Started with SPSS for Macintosh 

SPSS has a graphical interface consisting of pull-down menus, dialog boxes, and windows that display 
and organize data and perform numerical and graphical tasks. You can perform most tasks in SPSS by 
pointing and clicking the mouse. This section describes the basic features of the SPSS pull-down menus 
and windows.  

A basic familiarity with the Macintosh operating system is all you need to get started with SPSS.  

 

You can access SPSS on any Macintosh in the Meyer Library clusters from the Applications section of 
the Apple menu in the upper-left hand corner of the desktop. When you start SPSS, a screen like the one 
below will appear:  
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Note: The screen shown above may be partially obscured by a smaller window asking, “What do you 
want to do?” You can move to an empty data screen like the one above by clicking cancel. 

Like most Macintosh programs, SPSS has a menu bar with pull-down menus that you can use to access 
many of the features of the program. The following is a summary of the main pull-down menus and their 
functions: 

Menu Functions 

File Open and save data files, syntax files, and output files. Print 
files, and exit SPSS. 

Edit Modify or copy text, search for data or text, replace text. 

View Customize the look of the SPSS window by selecting to view the 
status bar, toolbars, grid lines and value labels. Change fonts. 

Data Sort data, merge files, subset data, and make other global 
changes to SPSS data files. Changes made are not permanent 
until you save the data file. 

Transform Make changes to selected variables or compute new variables. 
Changes made are not permanent until you save the data file. 

Analyze Perform statistical procedures to produce descriptive and 
inferential statistics. 

Graphs Create charts and graphs such as scatterplots, bar charts, line 
graphs and pie charts. For more information on using Interactive 
charts and on editing charts, see “Creating Charts and Graphs” 
on page 8. 

Utilities Display variable and file information, customize menus, create 
variable sets and autoscripts. 

Window Bring a different SPSS window to the foreground. 

Help Get help on SPSS procedures, use the SPSS tutorial, use the 
statistics coach. 
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SPSS Windows 

There are a number of different types of windows in SPSS. The following is a summary of the functions 
and contents of the most commonly used windows. 

The Data Editor window displays the contents of your data file in a spreadsheet format. This window 
usually appears when you launch SPSS. You can create new data files by entering data directly into the 
cells in the Data Editor window. You can also open existing data files and modify them in the Data 
Editor window. You can only have one data file open at a time in SPSS. 

The Viewer window opens automatically the first time you run a procedure that generates output. All of 
your statistical results, tables, graphs, and charts are displayed in the Viewer window. Any errors or 
warnings generated while running analyses also appear here. You can edit your output and save it for 
later use. 

The Chart Editor  window can be opened by double-clicking on any charts or graphs you have created. 
Within the Chart Editor window, you can modify your charts and graphs by changing colors, fonts and 
sizes. You can also add and edit chart and axis titles and labels, rotate 3-D charts, and even change the 
chart type. 

You can paste your dialog box choices into the Syntax Editor window, where the procedures will 
appear in command syntax form. You can then edit the syntax commands to utilize special features of 
SPSS not available through dialog boxes. You can also save your commands in a syntax file for use in 
future SPSS sessions. To paste dialog box choices into the Syntax Editor, click the Paste button instead 
of the OK  button when you are finished working with the dialog box. For more information, see “Using 
the Syntax Window” on page 7. 

Data and Variable Views 

SPSS has two different views: Data and Variable. You can choose one by clicking on the tab in the 
bottom left-hand corner of the window. You can use Data View for entering or looking at data, while 
you can use Variable View for changing the format and characteristics of variables For more 
information on these views, please see below. 

Working with Data Files 

Entering Data into SPSS  

After you launch SPSS, an empty Data Editor window titled untitled – SPSS Data Editor will appear. 
The Data Editor window consists of a grid of rows and columns. The rows correspond to cases, and the 
columns correspond to variables.  

There are several ways to enter data into the SPSS Data Editor window. You can enter data directly into 
cells in the Data Editor window. You can also open an existing SPSS for Macintosh or Windows file, 
open data files saved in selected other formats (e.g., SPSS Portable files and Excel spreadsheet files), or 
open ASCII (or text) files. 

To enter data directly into SPSS, type values into the empty cells and use the mouse, arrow keys, or tab 
key to move from one cell to another. For example, if you have data on the ages and heights of 100 
children, begin by entering the first child’s name, age, and height in the first row. (See below for an 
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example.) Then type the information for the second child in the second row. When you have entered all 
of the data, you will have a dataset with 100 rows and 3 columns. Your data will look like this: 

 

 

 

Opening Data Files  

Opening an Existing SPSS for Macintosh Data File: To work with an existing SPSS data file, launch 
SPSS and then select Open from the File menu and Data from the submenu. In the dialog box that 
appears, highlight the data file you want to open and click on Open. Note: SPSS 10 and higher will 
open SPSS files saved using SPSS for Windows as well. The data file will appear in the Data Editor 
window. To open an SPSS portable file (which can be read by any version of SPSS), use the same 
procedure, but select SPSS Portable under Show. 

 Opening Other Types of Data Files: SPSS can read data in several formats, including Excel, Systat, 
and Lotus files. You can usually open all files that SPSS recognizes by selecting Open from the File 
menu and Data from the submenu, choosing the relevant file type under Show, selecting the file, and 
clicking on Open. For more details, see the SPSS Base 10 User’s Guide or the SPSS 10 Syntax 
Reference Guide. You can read both manuals in the Velma Denning Room (Green Library Bing Wing 
Room 120F).  

Opening text (ASCII) Files: To open an ASCII (or text) file in SPSS, go into the File pull-down menu 
and select Read Text Data. In the dialog box that appears, select your file and click on Open. Once you 
have selected a file, the Text Import Wizard  will appear to help you with reading in the data. You need 
to tell SPSS whether your file matches a predefined format, how variables are delimited or arranged, 
whether you have included variable names, and so on. A preview of your file will be shown to help you 
remember its characteristics. Once you have entered the correct information, SPSS for Macintosh will 
import your data. 

Renaming a Variable/Working in Variable View  

By default, SPSS assigns the name “var00001” to the variable entered in the first column, “var00002”, 
to the variable in the second column, and so on. It is a good idea to give variables more descriptive 
names, such as “age” or “height”. To change SPSS default variables names, click the Variable View tab 
in the bottom left-hand corner of the Data Editor window.  

Once you enter the Variable View, each variable forms a row rather than a column. Variable formatting 
information is displayed in each column. You can click in any cell to edit the information it contains. 
For example, to change a variable’s type, click in its Type cell and choose the type in the dialog box that 
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appears. To change a variable’s width, simply click in its Width  cell, then use the up and down arrows 
to set the width. 

To rename a variable, click in its Name cell. To use a cursor, double-click in the cell; triple-click to 
highlight the entire variable name. You can then change the name of the variable by deleting the default 
variable name and typing your preferred name, such as “age,” in the Name cell. Your variable name may 
not be longer than eight characters, begin with a number, include non-alphanumeric characters 
(underscores are an exception), or contain embedded spaces. 

 

 

 

While in the Variable View, you may also want to define missing values for your variables (in the 
Missing column). You can also assign descriptive labels to the values of your variables using the Label 
column. Your label can be as long as 120 characters (e.g., Height in cm, shoes off). 

When you are done with editing variable formats, click the Data View tab in the bottom left-hand corner 
to return to your data. 

Saving Your Data Files  

To save data you have entered into the Data Editor window as an SPSS for Macintosh file, select Save 
from the File menu. In the dialog box that appears, type a name for your data file, select where you want 
to save it, and click on Save. Note: Saving your files on the hard drive of a public machine is not 
recommended.  

It is a good practice to give different types of SPSS files different extensions so they can be easily 
distinguished from each other. Additionally, if you add the correct extension to your file, it can be 
opened directly in SPSS for Windows. The file extension .sav (e.g., example.sav) is usually added to 
SPSS data files. Your saved file contains all of the values you entered, as well as the names of your 
variables, the labels you assigned to them, and any other formatting changes you made. 

Note: Be aware that when you save your data, it overwrites the specified data file. Any variables or 
cases that you have deleted or selected out will be lost. To retain the original file, click Save As instead 
of Save in the File menu, and give the altered data a new name. 

Moving Data Files Across Platforms  

If you plan to open your SPSS data files on other operating systems such as UNIX, save your data file as 
a portable file. A portable file can be read by any version of SPSS (for example, Macintosh, Windows, 
or UNIX). Note: If you are simply transferring your data between SPSS for Macintosh and SPSS for 
Windows, you do not need to change the file format. 

To save data as a portable file, select Save from the File menu. In the dialog box that appears, choose 
SPSS portable from the Format box. Then give the portable data file a name and click on Save. It is a 
good idea to give portable files a different extension from regular data files. For example, to save a file 
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named example.sav as a portable file, save it as example.por. Since example.por is a portable file, you 
can open it in SPSS for Windows or SPSS for UNIX. 

To use your SPSS data in another statistical software package such as Stata or SAS, you will need to use 
a data transfer program such as StatTransfer or DBMS/Copy. Information and software are available in 
the Velma Denning Room (Room 120F in the Bing Wing of Green Library). 

Analyzing Data 

You can perform most statistical procedures in SPSS using the pull-down menus or by typing 
commands in a Syntax window. Some advanced procedures and options can only be executed by typing 
commands in a Syntax window. The SPSS 10 Syntax Reference Guide is a good source of information in 
these situations. See “Using the Syntax Window” on page 7 for more information. 

Using the Analyze Pull-down Menu  

To perform a statistical procedure, use the Analyze pull-down menu to select the procedure you want to 
perform. For example, to produce descriptive statistics on a variable in your data (for example, the 
variable “age”), go into the Analyze menu, select Descriptive Statistics, and click on Descriptives in 
the submenu. A dialog box appears: 

 

In the Descriptives dialog box, click the age variable to highlight it, click on the right-pointing arrow to 
move it into the box labeled Variable(s), then click on OK . The descriptive statistics appear in an 
untitled Viewer window: 
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You can modify, save, or print the statistics in the Viewer window. For information about saving your 
output file, see "Saving Your Work" on page 9. 

To perform a linear regression, go into the Analyze menu, select Regression, and click on Linear  in the 
submenu. In the Linear Regression dialog box that appears, designate a dependent variable by selecting 
a variable from the list of variables and clicking on the right-pointing arrow next to the Dependent box. 
To designate an independent variable, move it into the Independent(s) box by selecting it and clicking 
on the arrow next to the Independent(s) box. Click on OK . 

 

  

 

The results of the linear regression will appear in your Viewer window. Additional regression options 
are available by clicking on the Statistics, Plots, Save, or Options buttons at the bottom of the Linear 
Regression dialog box. For example, you can request confidence intervals for your linear regression 
coefficients by clicking on Statistics before you perform your linear regression. In the dialog box that 
appears, click on the box labeled Confidence intervals, then click on Continue. 

Using the Syntax Window  

To perform some less common procedures and options, use the Syntax window. To open a Syntax 
window, select New from the File menu and choose Syntax from submenu. A Syntax window will 
appear in the foreground. Type SPSS commands and variable names in the window. For example, to run 
descriptive statistics on the age variable in the Syntax window, type:  

Descriptives variables=age.  

Descriptives is an SPSS command. It requires the subcommand variables and a list of one or more 
variables from the data file. The output will be the same as in the menu-based descriptives example 
shown above.  
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Type all commands in the first column of the line and end them with a period. You can find the syntax 
commands for statistical procedures in the SPSS manuals or in the SPSS Help window. (See "For More 
Information and Assistance" on page 10.)  

You can also insert commands into the Syntax window by selecting the procedure you want to perform 
from the Analyze pull-down menu and pasting it into the Syntax window. For example, to paste the 
commands for the linear regression procedure discussed in the previous section, open the Linear 
Regression dialog box from the Analyze menu, designate your dependent and independent variables, 
then click on Paste instead of clicking OK . SPSS automatically pastes the command into your open 
Syntax window, but it does not run the analysis. Here is the pasted syntax: 

 

 

 

To run commands in the Syntax window, highlight the commands you want to run using the mouse and 
click on the Run Syntax tool located on the tool bar. The run syntax tool looks like a single, right facing 
arrow. Alternatively, you can use the Run pull-down menu in the Syntax window. 

As usual, the output from your procedure will appear in your Viewer window. To save the information 
displayed in your Syntax or Viewer windows, see "Saving Your Work" on page 9. Using the Syntax 
window, you can keep a record of the analyses you have run. You can save your commands in a syntax 
file, then open them again later to duplicate or expand your analysis. This option can be very useful for 
long-term projects. 

Creating Charts and Graphs  

Use the Graphs pull-down menu to create graphs and charts. SPSS can create a wide range of graphs 
and charts and has lots of options for customizing them. For example, to create a scatterplot of the two 
variables “age” and “height”, go into the Graphs menu and select Scatter.... In the dialog box that 
appears, select Simple and then click on Define. Move the variable “age” into the X-axis box and 
“height” into the Y-axis box by selecting each variable and clicking on the right-pointing arrows next to 
each box. Then, click on OK . The graph will appear in the Viewer window: 
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Double-click on the scatterplot in the Viewer window, and a Chart Editor window will appear. Using the 
Chart Editor menus, you can add features such as a title to your charts and graphs and change the scale, 
range, or labels for your graph's axes. You can click on the axes or data points in your graph to select 
and edit them.  

Saving Your Work 

Save SPSS output, chart, syntax, and data files using the Save command in the File pull-down menu. 
For information about saving data files, see "Saving Your Data Files" on page 5.  

To save SPSS output files, including charts and graphs, move the output file to the foreground by 
clicking the SPSS Viewer box at the very bottom of your screen. Select Save from the File menu. In the 
dialog box that appears, type a name for your output file. In the Windows environment, output files are 
commonly given the extension .spo (e.g., example.spo). Use this extension if you ever plan to transfer 
your file to the Windows environment. Click on Save to save the output file.  

You could also export an SPSS output file in other formats to be able to view it when you do not have 
access to SPSS program.  To export an output file, go to the File menu in the output window and click 
on Export… .  In the dialogue box that appears, you may specify what output to export (charts or no 
charts, etc.), what path and file name to use for the exported output file, and what file format to use 
(html, word, text, or excel spreadsheet).  

To save the information in your Syntax window, be sure that the syntax window is in the foreground and 
select Save from the File menu. Syntax files are given the extension .sps (e.g., example.sps) in the 
Windows environment. Click on Save to save your syntax file.  
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After you have saved an output, syntax or chart file, you can open it by selecting Open from the File 
menu, then choosing the file type from the submenu. In the dialog box that appears, locate the file you 
want to open, select the file name and click on Open.  

Printing Files 

You must purchase print quota to print at the Meyer or Tresidder clusters. More information about this 
can be found at http://www.stanford.edu/services/cluster/printing. 

To print numeric output such as frequencies or regression results, make sure the Viewer window is in 
the foreground and select Print  from the File menu. If you want to print only a portion of your Viewer 
window, you can do so if your printer has the correct option. Highlight the desired section by clicking in 
the area on the left-hand side of the window. Then, select Print  from the File menu. You may be able to 
click a Selection button in the Print Range area of the Print dialog box, then click OK .  

You can also print syntax files. Choose Print from the File menu once the Syntax window is in the 
foreground.  

For More Information and Assistance 

SPSS Help  

SPSS has an extensive hypertext Help system that provides information about using SPSS and 
understanding the results. To access the SPSS Help system, go to the Help menu on the far right side of 
the screen and select an option.  

The Topics command allows you to access a standard-format help system. You can view a wide variety 
of topics using a table of contents, an index, or a search function.  

Using the Tutorial  option, you can access a large number of how-to descriptions for SPSS procedures. 
The tutorial database is a detailed, useful resource for users with specific questions. 

Users can access the SPSS Home Page from the Help menu. This resource contains much up-to-date 
information about SPSS. 

The SPSS Statistics Coach is an excellent resource for new SPSS users. This interactive guide asks 
what you want to do, then leads you through the necessary steps for completing the desired analysis. For 
example, if you want to present descriptive statistics for some variables, you should tell the Statistics 
Coach that you want to Summarize, describe, or present data, then click Next. If you want to look at 
the continuous variable Age, then select the Continuous, numeric data option and click Next. Tell the 
statistics coach that you want to present Tables and numbers and click Next. Then choose Descriptive 
statistics plus quartiles, quantiles, and percentiles and click Next. The Statistics coach opens a how-
to page for obtaining descriptive statistics, including a Tell me more… button that provides more 
information. 

Another extremely useful resource is the SPSS Results Coach. Once you have performed an analysis, 
this interactive help system helps you interpret the results. To access the Results Coach, you must first 
have performed an analysis and have results open in the Viewer window. There are two ways to open 
the Results Coach. You can either right-click on the results you want to interpret and select Results 
Coach from the menu, or you can double-click on the relevant results and choose Results Coach from 
the Help menu. The coach tells you what the categories and numbers presented in the output mean, and 
sometimes suggests other ways of displaying the same type of information. 
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SPSS Computer-based Tutorials (CBTs) 

SPSS has produced two extensive computer-based tutorials (CBTs) for users who want to learn more 
about the software. The tutorials are Windows-based, but are essentially the same as SPSS for 
Macintosh. The Basic and Intermediate tutorials are both available in the Velma Denning Room (Green 
Library Bing Wing room 120F) and on computers #1-6 in the Jonsson Social Science Reading Room 
cluster in the Bing Wing. To access them, double-click on the “SPSS CBT Basic” or “SPSS CBT 
Intermediate” icon on the desktop. The tutorials are arranged by subject. For example, if you simply 
want to know more about graphing, you can choose only to view the tutorial segments related to this 
topic. Allow several hours to go through an entire tutorial. 

Documentation  

The following books and manuals contain useful information about using SPSS. The introductory guides 
may be particularly helpful for new users. You can read and photocopy them in the Velma Denning 
Room (Green Library Bing Wing room 120F) or purchase them at the Stanford Bookstore. Some SPSS 
manuals are also available to be checked out from Green Library Reserves.  

SSDS Software Services at Stanford  

Software Services provides technical support for SPSS users at Stanford.  Users can ask questions or 
make appointments with the consultants via our website. For more information or to contact us, see the 
web at:  

http://ssds.stanford.edu/ 

Note:  This document is based on SPSS 11 for Mac. 
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