Educator’s Guide to ArcView® GIS

Larry P. Kendall
Contents

Introduction

Preface .......................................................................................................................... 1
The ArcView user interface ......................................................................................... 3

Basic techniques

Theme basics ............................................................................................................... 4
Panning and zooming ................................................................................................. 6
Editing legends .......................................................................................................... 8
Changing scale and projection .................................................................................. 12
Measuring .................................................................................................................. 14
Working with attribute tables .................................................................................. 16
Editing data ............................................................................................................... 19
Using Boolean operations ......................................................................................... 20
Finding features with queries ................................................................................... 22
Using Select By Theme ............................................................................................ 24
Creating layouts ........................................................................................................ 26
Preface

We live in an information age. Maps and databases are a part of our daily life. Chances are you have already used several kinds of maps today for one purpose or another. You even carry mental maps in your head, containing information that you use frequently.

What is a GIS?

A Geographic Information System (GIS) combines maps and information about map features with the interactive visualization and analytical power of computers. The result is a powerful tool for working with spatial data. GIS is used by, or at least affects, people of nearly every walk of life. After all, there’s no shortage of geographic data. As GIS users are quick to point out, “Everything happens somewhere!”

Using this guide

This guide was designed as a quick reference to the basic functions of the ArcView GIS software package, not as an exhaustive manual. It was prepared as a supplement to the GIS-based science curriculum materials developed by The SAGUARO Project at the University of Arizona.

Our experience in using and testing these materials has taught us that it’s usually only necessary to give students a 5–10 minute introduction to these essential skills before they use ArcView for the first time.

- navigating the ArcView user interface (Page 3)
- turning themes on and off (Page 4)
- activating themes (Page 4)
- panning and zooming (Page 6)

Beyond these basics, students will learn nearly everything they need to know about ArcView by simply using it as a tool and following the directions provided in the materials. The other techniques in this guide may be of interest as students become more familiar with ArcView and begin to use it to explore “outside the box,” seeking answers to their own questions.

A work in progress

This document is a work in progress, and can only become more useful through user feedback. Your ideas and suggestions for improvement are welcomed. Please direct comments and inquiries to us at saguaro@geo.arizona.edu.
2 Preface
The ArcView user interface

ArcView GIS provides tools for working with information in the form of maps (called views), tables, charts, layouts, and scripts. The collection of information you are working with at any given time in ArcView is called a project, and the computer file that describes how the project components are displayed is the project file. The name of this file ends with .apr, which stands for ArcView Project. Each project component has its own user interface, with an appropriate set of tools, buttons, menus, and windows. This example names and describes the parts the Views interface.

Note - this view shows the Macintosh user interface. The Windows interface is virtually identical except that the status bar is at the bottom of the application window.

The ArcView User Interface
Points, lines, and polygons
These are the three basic types of spatial data. (For you math lovers, they have 0, 1, and 2 dimensions respectively.) Which is used to represent a feature often depends on the extent of the map. Some examples are:

- **Points** - cities, landmarks, survey points
- **Lines** - roads, pipelines, trails
- **Polygons** - boundaries, buildings, regions

Theme basics

In a GIS, a set of geographic features that share similar characteristics is called a **theme**. A **view** is a map of one or more themes displayed on a common coordinate grid.

The table of contents

The table of contents lists the themes that have been added to the view and displays each theme’s legend. Manipulating the table of contents changes the appearance of the view.

Adding a theme to a view

To add a new theme to a view:
- Choose View > Add Theme... or click the add theme button and select a theme to add. The theme will be added to the top of the view’s table of contents, but will not be turned on.

Turning themes on and off (Essential Skill)

Whether a theme is displayed or hidden depends on whether or not that theme is turned on or off in the table of contents.
- Click an unchecked box to turn that theme on.
- Click a checked box to turn that theme off.

Activating themes (Essential Skill)

To work with a theme, it must be active.
- To make a theme active, click the theme’s title in the table of contents. A raised border highlights the active theme.
- To activate or deactivate multiple themes, hold down the shift key and click on additional theme titles. Each active theme will have a raised border.

Timesaving tip

The more themes that are displayed, the longer it takes to redraw when you make a change to the view. To reduce the redraw time, turn off any themes you don’t need.

Displaying shortcuts

Hold down the control key while clicking the box to turn all of the themes in a view on or off.

Educator’s Guide to ArcView GIS

4 Theme basics
Deleting themes

Turning a theme off causes that theme’s features to not be displayed, but the theme’s data is still part of the project. To permanently remove a theme’s data from a project:

- Activate the theme(s) you want to delete.
- Choose Edit ➤ Delete Themes.

Changing the draw order of themes

A theme represents features as points, lines, or polygons (areas). If more than one theme is turned on, they are drawn on the map as layers. These layers are drawn in order, starting at the bottom of the table of contents. Polygon themes, such as states or counties, may cover point or line themes, such as cities or rivers, that are lower in the table of contents.

If you don’t see a theme drawn in the map, first check to see that the theme has been turned on. Then check to see if a polygon shape is covering it. To change the drawing order of a theme, drag the theme title up or down to a new position in the table of contents. In general, move point themes to the top of the table of contents, line themes to the middle, and polygon themes to the bottom.

Changing theme names

You may want to change the names of themes listed in the table of contents to make them easier to read or understand. For example, how many people would guess that ftc_crs.shp represents points on a fitness course trail? To edit the name of a theme:

- Make the theme active in the table of contents.
- Choose Theme ➤ Properties....
- Edit the name in the Theme Name box and click OK.

Changing the name of a theme changes the way the name is displayed in the project, but does not change the name of the original data file.

Editing theme legends and data

Themes can be edited in several ways. Two sections of this guide cover additional editing operations:

- Editing legends explains how to modify the colors and symbols used to display the theme in the map.
- Editing data explains how to add, delete and modify theme data.
Panning and zooming

**Panning (Essential Skill)**

Panning moves the map within the View window without changing the scale or the extent (see sidebar). To pan, click and drag the map with the pan tool in the direction you want it to move. When you release the button, the missing parts of the view will redraw.

**Selected features**

Selected features are highlighted in yellow in both the View window and in the theme’s attribute table. See Selecting Features on page 22 for more information.

**Zoom to Full Extent**

This button scales the map so that all of the features of all of the themes will fit in the view, whether they are displayed or not.

**Zoom to Active Theme(s)**

This button scales the map so that all of the features of the active theme will fit in the view, whether they are displayed or not.

**Zoom to Selected**

This button scales the map so that the selected (highlighted) features of the active theme will fit in the view, whether they are displayed or not.

**Are you lost in your view?**

If one or more themes are turned on but you don’t see any features or can’t figure out where you are in the view, click the Zoom to Full Extent button to regain your sense of place.

**Zoom buttons**

The six zoom buttons are grouped on the Views button bar:

- Zoom In
- Zoom Out
- Zoom to Full Extent
- Zoom to Active Theme(s)
- Zoom to Selected Features
- Zoom to Previous Extent

**What’s an “extent”?**

The extent is the geographic area that’s displayed in the View window.

**Selected features**

Selected features are highlighted in yellow in both the View window and in the theme’s attribute table. See Selecting Features on page 22 for more information.

**Using the zoom to extent buttons**

The three zoom to extent buttons allow you to quickly fill the view with an area of interest. The view below contains two themes: countries of the world and the United States. The States theme is active, and Montana has been selected (highlighted) with the Select Feature tool. If map units are set, the scale of the map is displayed in the scale box on the right end of the tool bar.

If you are lost in your view, click the Zoom to Full Extent button to regain your sense of place.
Other zoom buttons

ArcView gives you other ways to zoom in and out:

- To zoom in to the center of the view, click the Zoom In button.
- To zoom out from the center of the view, click the Zoom Out button.

Zooming tools

ArcView has two zooming tools—the Zoom In tool and the Zoom Out tool. To use them, activate the tool and click on the view. The view will zoom in or out, centered on the location you clicked.

The Zoom In tool also lets you click and drag in the view window to define the zoom extent.

Oops! How do I undo a zoom?

To undo a zoom, click the Zoom to Previous Extent button. ArcView lets you “step back” through the five most recent extents or zooms.
The Legend Editor allows you to change the colors, patterns, lines, and symbols used to draw the features on a map.

**Legend Editor basics**

- To edit a theme’s legend:
  - Double-click the theme name in the table of contents (shown at right).
  - Choose the legend type, classification field, and type of classification (if appropriate).
  - To change a symbol, double-click the symbol in the Legend Editor window and use the Symbol Window to change the symbol’s appearance. (See Editing symbols below.)
  - Click the **Apply** button and close the Legend Editor window.

**Editing symbols—the Symbol Window**

- To edit a legend’s symbol:
  - Double-click the symbol in the Legend Editor window to open the Symbol Window.
  - Click the appropriate palette buttons and make the desired changes.
  - Close the Symbol Window.

The symbol window contains six palettes for setting the properties of map symbols:

- **Fill Palette**—Choose the type of fill pattern for polygons.
- **Pen Palette**—Change the thickness and style of lines used in line themes and polygon borders.
- **Marker Palette**—Select the type of marker used for point themes.
- **Font Palette**—Change the size, type, etc. of text in a theme.
- **Color Palette**—Change the symbol’s color.
- **Palette Manager**—Reset the palettes to their default settings.

- Click the **Apply** button in the Legend Editor.
Legend types

ArcView offers several types of legends, each suited to particular kinds of data. To choose a legend type, click on the legend type pop-up menu and make an appropriate selection.

Single Symbol

Single Symbol is the default legend type. It shows all of the features of the theme using a single color and symbol.

To revert back to a single symbol legend:
- Choose Single Symbol from the Legend Type popup menu.
- Double-click the symbol, choose a color from the Symbol Window, and close the Symbol Window.
- Click the Apply button.

Unique Value

Displays all features sharing the same value as a unique color.

To create a unique value legend:
- Choose Unique Value from the Legend Type popup menu.
- Choose a Values Field from the popup menu.
- Choose a color scheme from the Color Schemes popup menu.
- If necessary, edit individual legend colors.
- Click the Apply button.

Legend classification

What is classification?
Classification sorts data values into groups so that unique symbols can be assigned to each group. Graduated Color and Graduated Symbol legends divide the values of a field into groups or classes, so that a color or symbol can be assigned to each value.

To set the type of classification, the number of classes, and the number of decimal places for classification values, click the Classify… button in the Legend Editor window.

Types of classification
- Equal area - the features of each class contain about the same total area.
- Equal interval - each class has the same value range.
- Natural breaks - ArcView looks for clusters of data and breaks these clusters into separate classes.
- Quantile - each class contains about the same number of features.
- Standard Deviation - values are classified according to how far they are above or below the average value.
Graduated colors or graduated symbols?
Graduated color legends are good for displaying qualitative or relative attributes like population density, percent unemployment, and birth rate.

Graduated symbol legends are usually best for showing quantitative (how many, how big, etc.) attributes like population, magnitude, and agricultural production.

Normalizing data
When using Graduated Color or Graduated Symbol legends, in addition to classifying single attributes, you can classify data based on the relationship between two attributes. Called normalizing, this is done by dividing the value of one field (the classification field) by the value of another field (the normalization field).

In this example, the 1990 population of each state is normalized by that state’s area. The resulting values are the population per unit area (also called the Population Density).

Graduated Color (points, lines, or polygons)
Displays a theme in a graduated spectrum of colors based on the values in one field of the theme’s attribute table.

To create a graduated color legend:
- Choose Graduated Color from the Legend Type popup menu.
- Choose a Classification Field from the popup menu. (See Legend classification on Page 9).
- Click the Classify… button. Choose the type, number of classes, and precision of the values, then click OK.
- Choose a color scheme from the Color Ramps popup menu.
- Click the Apply button.

Graduated Symbol (points or lines only)
Graduated symbol legends are similar to graduated color, except that each class has a unique size (or width) of marker or line. The colors of the symbols can be set manually.

To create a graduated symbol legend:
- Choose Graduated Symbol from the Legend Type popup menu.
- Choose a Classification Field from the popup menu. (See Legend classification on Page 9).
- Click the Classify… button. Choose the type, number of classes, and precision of the values, then click OK.
- Choose a color scheme from the Color Ramps popup menu.
- Click the Apply button.
**Chart**

Chart legends display data using pie or bar graphs. These are useful when you want to compare the values of two or more different field values for each feature. Here, the 1990 and 1996 state populations are displayed in a bar chart.

To create a chart legend:

- Choose **Chart** from the **Legend Type** popup menu and click the desired **Chart Type**.
- Choose each field you want added to the chart and click **Add**.
- Double-click the symbol for each field and choose an appropriate color and fill pattern for each symbol.
- Double-click the **Background Symbol** and choose an appropriate color and fill pattern.
- Click the **Apply** button.

**Dot (polygons only)**

Displays data by filling the polygon with a dot density profile (the higher the value, the more dots).

To create a dot legend:

- Choose **Dot** from the **Legend Type** popup menu.
- Choose a **Density Field** from the popup menu.
- Enter a **Dot Legend** value (1 dot = ____) or click the **Calculate** button to have ArcView calculate the value for you.
- Double-click the **Dot Symbol** and choose a symbol type and color.
- Click the **Apply** button.
Changing scale and projection

Map scale

A map scale represents a comparison of the distance between two points on a map to the distance between corresponding points on the ground.

Scale in ArcView GIS

The scale of a view is shown on the right end of the tool bar. The scale updates automatically as you zoom in or out.

What if the scale is blank?

For ArcView to calculate a view’s scale, the map and distance units of the view must be set. Instructions for setting map and distance units are given in the section on Measuring on page 14.

Manually changing the scale

To manually change the scale of a view, click in the scale box and enter the new scale in the dialog box that appears. (see page 7 for more on the view scale)

Scale and detail

The scale of a map determines how much detail can be seen.

- **Large-scale maps** (like city maps) show small areas in greater detail.
  Example - 1:24,000

- **Small-scale maps** (like road atlases) show larger areas, but in less detail.
  Example - 1:1,000,000

If this is confusing, remember that the fraction represented by the scale ratio of the small-scale map (1/1,000,000) is much smaller than that of the large-scale map (1/24,000).
**Projections**

A projection mathematically transforms a curved surface onto a flat map while attempting to preserve the property of area, shape, or distance. (Or any two, but never all three!)

In ArcView, all themes in a view must be in the same projection to display properly.

**Changing a view’s projection**

If your theme data are unprojected (that is, in geographic coordinates or decimal degrees), they can be displayed in any of ArcView’s built-in projections.

- To change a View’s projection:
  - Choose View > Properties
  - Click the Projection button
  - Choose a category and a type of projection from the popup menus.
  - Click OK.

### Types of projections

**Cylindrical**

The surface is projected onto a cylinder that touches the globe at the equator, maintaining the scale on lines of longitude (meridians) and at the equator. Best used for equatorial projections of the world.

**Planar**

The surface is projected onto a plane that touches the globe at one of the poles, the equator, or some other point.

**Conical**

The surface is projected onto a cone that touches the globe on any circle drawn around the globe. A conical projection shows true scale along the meridians and one or two circles of latitude (parallels). Most useful for map areas that extend in an East-West direction.
Measuring

Setting and changing map and distance units

Before you can measure distance or area in a view, the map and distance units must be set. To find out if they are already set, choose View ➤ Properties…. If the Map Units and/or the Distance Units are listed as unknown, set the known units from the respective popup menus. The map units are determined by the projection. If the data are unprojected, set the map units to decimal degrees. The distance units are determined by the user’s needs. To change map or distance units, choose the desired units from the appropriate popup menu.

Measuring distances

To measure distances in a view:
- Zoom in using the zoom in tool until the feature(s) you want to measure fill the view window.
- Using the measuring tool, click on one feature, move to the other feature and double-click. The distance will be given in the status bar.

To measure distances along irregular paths:
- Click once to begin, single-click at each point where you need to change direction, then double-click at the end.
- The status bar displays the length of the current segment (since the previous click) as well as a running total of the segment lengths.
Measuring areas

To measure an area:

- Choose an appropriate tool from the drawing tools popup menu. (shown at right)
- Draw the shape and read the area on the status bar. For rectangles, the status bar shows the height and width of the rectangle, for circles the radius, and for polygons the perimeter. Hold down the shift key to draw squares and circles.
- You can read the area of rectangles and polygons in the status bar by selecting the shape with the pointer tool.
- To delete a drawn shape, select it with the pointer tool and press the delete key.

Measurement accuracy

ArcView is designed to calculate distances correctly for unprojected data. You can measure distances and areas in projected views, but the accuracy varies with the projection and generally decreases as the view extent increases.
Working with attribute tables

Descriptive information for each feature in a theme is stored in a database called an attribute table. Within the table, the data values are arranged in records (rows) and fields (columns):

Field (column) - contains the values of a single attribute for all of the features in the theme.

Record (row) - contains all of the attributes for a single feature.

Value (cell)

Scroll bars - scroll to see the rest of the table

Resize box - drag to change the size of the table window.

Identifying features in the view window

- To identify a feature in a view window:
  - Make the feature’s theme active in the table of contents.
  - Click on the feature using the identify feature tool. The attributes for the feature will be displayed in the Identify Results window.

Opening a theme’s attribute table

- To open a theme’s attribute table:
  - Make the theme active in the table of contents.
  - Click the open theme table button.
Finding features by text attributes

Finding features in View windows
The find button [A] locates features by name (or other text attribute) and highlights and centers them in the View window.

- To find features by name (or other text attribute):
  - Make the features’ theme active in the table of contents.
  - Click the find button [A].
  - Enter the text you want to find in the Find Text in Attributes dialog box and click OK. If the text occurs more than once in the table, you must repeat this process until the desired feature is found.

Finding features in Table windows
The Tables interface also has a find button [A]. This button works the same as in the View window, except that found features are not automatically centered in the View window.

Selecting table records
There are several ways to select records in a table. In each case, both the selected records in the Table window and the features in the View window will be highlighted yellow.

- In the Table window, by clicking them with the pointer tool [A].
- In the View window, by clicking on features or dragging a rectangle around them with the select features tool [A].
- Making a query. (see page 22)
- Performing a Select By Theme operation. (see page 24)

Manipulating selected records
ArcView includes additional buttons for manipulating selected records:

Switch Selection [O]
To select all of the features that are currently not selected, and deselect the features that are currently selected, click the switch selection button [O]. This is particularly useful when querying a theme, to get the results that do not meet the query’s selection criteria.

Promote Records [E]
Click the promote records button to move all of the selected records to the top of the attribute table. This makes the selected records easier to view.
Sort Ascending/Descending

Sorting a field makes it easier to quickly see its maximum and minimum values.

- To sort a field into ascending (A-Z) or descending (Z-A) order:
  - Click on the field label to select the field.
  - Click a sort button.

Select All/Select None (Clear)

These buttons make it easy to select all or none of a table’s records. The View interface also contains a select none button.

How many features are selected?

To find out how many records are in a table and how many of them are selected, open the attribute table and look at the Table status bar:
Editing attribute tables

If you discover incorrect or outdated information in an attribute table, or want to fill in missing attributes, you can edit the table values.

- To edit a table:
  - With the table open, choose Table ▶ Start Editing.
  - Click in the table cell with the edit table tool.
  - Repeat for additional cells. After editing the last cell, be sure to press return to accept the last cell value entered.
  - Choose Table ▶ Stop Editing. When prompted to save your edits, click OK.

Editing features in a view

You can add new features or edit existing features in a view.

- To edit features in a theme:
  - With the view open, choose Theme ▶ Start Editing.
  - Use the pointer tool to select and move features, and the vertex edit tool to change their shapes.
  - When you are finished making changes, choose Theme ▶ Stop Editing. When prompted to save your edits, click OK.

- To add features to a theme:
  - While in edit mode, use an appropriate drawing tool to draw the new feature. The tool must match the type of theme—either the point tool, a line tool, or one of the area tools.
  - Open the theme’s attribute table and scroll to the bottom record. This is the new record. Enter attribute values as described above.
  - Choose either Theme ▶ Stop Editing or Table ▶ Stop Editing. When prompted to save your edits, click OK.
A typical use of a GIS is to find features that match certain requirements. This process is called a query. Designing queries involves logic, and logic uses a special type of mathematics called **Boolean mathematics**. (see sidebar)

**Boolean expressions**

Simple queries are Boolean expressions—comparisons of two things using a relational operator. Evaluating an algebraic expression produces a single numerical value; evaluating a Boolean expression produces a single **logical** value, either TRUE or FALSE.

**Boolean operators**

A Boolean or logical operation generally operates on two Boolean expressions and returns a logical value of TRUE or FALSE. Querying selects database records that meet specific requirements or criteria.

Sometimes the information you want must meet two or more criteria. You can do this with two or more simple queries, or by making one complex query using logical, or Boolean operators. The three Boolean operators available in ArcView are AND, OR, and NOT.

- **AND** - selects the features that match both criteria.

\[
A \text{ AND } B
\]

- **OR** - selects the features the match either criteria.

\[
A \text{ OR } B
\]

- **NOT** - selects the features that don’t match a given criterion.

\[
\text{NOT} \ (A \text{ AND } B)
\]
**Syntax—grammar for queries**

In ArcView, each table record is evaluated according to the Boolean expression or operation created in the **Query Builder** and is selected if the record meets the criteria (TRUE) or is excluded if it does not meet the criteria (FALSE).

Queries are written using a set of grammatical rules, called a syntax. The basic syntax for a Boolean expression is:

```
field name   operator   value
[Magnitude]  >=         6.0
[State]      =           "Texas"
```

Field names are enclosed in square brackets, text criteria are enclosed in quotation marks, and numerical criteria are written as decimal numbers without units.

The structure of the **Query Builder** window also follows this syntax:

```
field name (double-click)                       relational operator (single-click)                       value (double-click)
[Month]         <>             29
[Day]           >               30
[Time]          >=              31
[Lat]           <               32
[Long]          <=              33
[Depth]         (double-click)     (single-click)     (double-click)  
(Magnitude)    >=              (Depth) <          7, and 33
```

The result of a query is that both the features that match the criteria are selected (highlighted), both in the view window and the attribute table.

**Relational operations**

Relational operations are used to compare two things. Common relational operators are:

- = equal to
- <> not equal to
- > greater than
- >= greater than or equal to
- < less than
- <= less than or equal to

**Set operations**

It's possible to do quasi-Boolean queries using the Query Builder's set operation buttons.

- **New Set** selects all records in the theme that match the criteria.
  
  `[Magnitude] >= 5`  
  
  Result: all earthquakes in the table whose magnitude is greater than or equal to 5.

- **Add To Set** adds records that satisfy the current query to the set of previously selected records. Add To Set is equivalent to the OR Boolean operation.

  `[Depth] <= 200`  
  
  Result: all earthquakes in the table whose magnitudes are greater than or equal to 5 and whose depths are less than 200 kilometers.

- **Select From Set** refines a selection and gets a subset of the previously selected data. Select From Set is equivalent to the AND Boolean operation.

  `[Location] = "US*"`  
  
  Result: earthquakes whose magnitudes are greater than or equal to 5, depths are less than 200 kilometers, and that occurred within the United States.
Finding features with queries

Queries are powerful tools for selecting or displaying the features in a theme that match specific requirements, or criteria. Queries are used to investigate problems and answer questions. ArcView provides two types of queries—one for selecting features, and another for filtering features.

**Selecting features**

A selection query displays all the features in a theme and highlights the features that meet the specified criteria. To make a selection query, click the query builder button.

### Set operations

You can do one of three things with the features selected by a query:

- **New Set** highlights all of the features in the entire theme that match the query. For example...
  
  ```
  ([Magnitude] = 5)  
  ```
  
  ...selects all magnitude 5 earthquakes.

- **Add To Set** combines the features selected by a query to any previously selected features. For example...
  
  ```
  ([Magnitude] = 6)  
  ```
  
  ...selects magnitude 5 and 6 earthquakes.

- **Select From Set** produces a subset of the selected features. For example...
  
  ```
  ([Month] = "May")  
  ```
  
  ...selects magnitude 5 and 6 earthquakes that occurred in the month of May.

### Converting selected features to a Shapefile

After querying a theme, you can create a new theme containing only the selected features by choosing Theme Convert to Shapefile.

### Unselecting features

To unselect features so that they are no longer highlighted, click the clear selected features button in either the view window or the theme table.

The basic form of a query is:

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Operation</th>
<th>Value</th>
<th>Set Operation</th>
</tr>
</thead>
</table>

- To query a theme, turn the question above into an expression using the field names, operations, and values.
  - Double-click the Field Name (Magnitude)
  - Single click the operation (=)
  - Double-click the Value (5).
  - Click either New Set, Select from Set, or Add To Set to select the features that meet your criteria. (see sidebar)
Filtering features (theme table queries)

Sometimes a theme has so many features that the view is difficult to interpret, or just looks crowded. A filter query displays, in the view window, only the features that match the criteria. The features that don’t match the criteria are hidden.

To display all of the features of the theme again, choose Theme ➤ Properties, and click the Clear button.

**How many features?**

After querying a theme, the number of features selected is displayed on the status bar. Click the open theme table button to open the active theme’s attribute table.

<table>
<thead>
<tr>
<th>selected features</th>
<th>total features</th>
</tr>
</thead>
<tbody>
<tr>
<td>28</td>
<td>51</td>
</tr>
</tbody>
</table>

The records (table rows) for the features that are selected are also highlighted in yellow. To move all of the selected features to the top of the table, click the promote button.

For additional information about working with attribute tables, see the section on Tables on page 16.

**Spatial Queries**

Another type of query is known as theme-on-theme selection. This allows you to select certain features based on their spatial relationships to features in other themes. This is discussed in the section on Select By Theme on page 24.

**Example**

“Show only the tornados in Arizona that resulted in injuries.”

Click here to clear the filter and display all features in the theme.

Result: Only the injury-causing tornados are displayed in the view and attribute table.
Using Select By Theme

Spatial queries
Queries select features according to specific criteria. Unfortunately, they work only within a single theme. With ArcView, you can also perform spatial queries between themes. That means you can select features in one or more themes based on their spatial relationship to features in another theme. This is called a theme-on-theme selection. In ArcView, the command that carries out this operation is called Select By Theme.

An example
Like an attribute query, a spatial query starts with a question:
“Which schools and churches are within 1/2 mile of Central Park?”
- To translate this question into a Select by Theme operation:
  - Use any selection technique to highlight the known feature(s) in the appropriate theme. [Central Park]
  - Make the themes containing the features you want to identify active in the table of contents. (Shift-click on additional themes to activate more than one theme.) [Schools and Churches]
  - Choose Theme ➤ Select By Theme.
  - Choose a spatial operation. [Are Within Distance Of]
  - Choose a selector theme. [City Parks]
  - Optional - When using Are Within Distance Of, enter a distance. [0.5 mi]
  - Click the appropriate set operation button. [New Set]
A note on NOT

Selecting the features of a theme that do not meet certain criteria—do NOT intersect another theme, or are not within some distance of another theme—takes an added step.

- To select the features that do not match your criteria:
  - Select the features that do meet the criterion using the procedure outlined earlier.
  - Click the open theme table button to open the active theme’s attribute table.
  - Click the switch selection button.
Creating layouts

A layout is used to present a view, or several views, in a map-like presentation setting, with standard cartographic elements.

Creating automatic layouts

- To create an automatic layout:
  - Prepare your map in a view window.
  - Choose View... ▶ Layout and select an appropriate layout template, and click OK.
  - You may add, delete, or modify layout elements manually.

Creating custom layouts

- To make a custom layout:
  - Select the Layout icon in the Project window and click the button to create a new layout window. A blank layout page will open with new buttons and tools available.
  - The default layout is vertical (portrait format). To make a horizontal layout (landscape format), choose File ▶ Page Setup....

Elements are added to the layout by creating boxes called frames, and linking them to existing project element, map feature, or graphic to fill the frame.

View Frame Tool

- Adds a selected view to a layout.

Legend Tool

- Adds a legend for a selected view.

Scale Bar Tool

- Adds a scale bar for a selected view.

North Arrow Tool

- Inserts a North arrow.

Chart Frame Tool

- Inserts a chart based on one or more fields of a selected theme.

Table Frame Tool

- Inserts a table from the selected theme.

Graphic Frame Tool

- Inserts an imported picture in a layout.

Frame Tools

The Frame tools are on a pop-up menu on the Layout tool bar. Use these tools to create frames for views, legends, scale bars, north arrows, tables, and charts to your layout.

To use a frame tool, click and drag to create a rectangular frame on the layout, then choose an existing project element, map feature, or graphic to fill the frame.

Editing layouts

There are other tools that will allow you to edit the appearance of your layout.

- Add text, such as a title to a layout.
- Move graphics in front of or behind each other.

Zooming in layouts

The Layout button bar has several zoom options that are similar in function to the View zoom options.