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Working with Point Clouds in CloudCompare; classifying with CANUPO
This assignment follows Sheep Draw SfM and uses an Open Source software, CloudCompare (https://www.danielgm.net/cc/) that allows for viewing and manipulation of point clouds. This exercise will walk you through 1) basic operations and use in CloudCompare, and 2) use of an Open-Source plugin in CloudCompare called CANUPO (http://nicolas.brodu.net/en/recherche/canupo/) that allows for point cloud classification.  This unit can be used with any point cloud dataset. 
Questions or comments please contact education AT unavco.org. Version July 17, 2020.	Page 8
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Part 1: CloudCompare
Install CloudCompare https://www.danielgm.net/cc/. Open CloudCompare application and then navigate in the toolbar to File >> Open. Open your text file you saved from the Sheep Draw exercise (or other text file, as appropriate). 

[image: ][image: ]

Note that an Asccii File is simply a text file. Make sure CouldCompare is reading the file in correctly (it shows a preview). In this case, it has chosen the formatting correctly. Click “Apply” and wait for the point cloud to load. It will ask if you want a shift in coordinates (for its own internal computation and display purposes). Say ok. 
[image: ]
The display should look similar to that in Metashape. You can zoom by scrolling your mouse. You can also change the view orientation and drag the cloud by clicking the right mouse button. You can also zoom by using the 3D Views drop down menu. Lastly, you can use the left panel “Viewing Tools” to change the view. 

Step 1 
Save an image with a cool view of your site by using the dropdown menu Display >> Render to File to save the view as an image. To make sure you keep the scalebar and orientation icon, go to Display >> Render to File and click the “Render Overlay Items.” Resave the image and it should now have a scalebar and orientation icon. Notice that we are viewing the point cloud with x,y,z information but also with color, because the drone flight used and RGB camera and thus has an RGB assignment for each point. We can switch to an elevation color map by assigning elevation as a scalar field and then coloring by this scalar value (elevation). 
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Note: If your computer is struggling with a large cloud, you can subsample the cloud from the Main Tools Menu 
[image: ]
Step 2
Change the color you are viewing by assigning elevation as a scalar field. Go to Edit from the dropdown menus Edit >> Scalar fields >> Export coordinate(s) to SF(s) and just check “Z” (X and Y are already assigned as a scalar field). 

 You can change back to RGB by changing the Colors dropdown menu in the Properties panel. 
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[image: ]You can also change the color scale and whether the scalebar is visit by changing the “Color Scale” properties in the Properties Panel. You can also access this from the “Main Tools” menu.
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[image: ]Change back to RGB by changing the “Active Scalar Field” to none and the “Colors” drop down (located at the top of the Properties Panel) back to RGB. 

Step 3
Use the cloud to measure a feature. 
From the Main Tools Menu, measure the distance between two points 
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There will be a small menu in the upper right: 
[image: ]
From this menu, play with the distance and angle tools. I chose to pick the collapsed bank:
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From the information on changes in x,y, and z. 

Step 4
Measure geometry of an object more accurately by fitting a plane to a feature of interest and determining its slope. Cut out the feature of interest, so you will be fitting a plane to only that feature. Use the polygon shape and right click when finished. 
[image: ] Then use cut out the feature [image: ] Click the green check mark if you are happy with your result. Check off the remaining cloud and you will have your area of interest.
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Go to the Tools menu, Tools >> Fit >> Plane and fit a plane to the surface. In the point cloud menu, you will now see the dip and dip direction: 
[image: ]
In this case, the dip is 51 degrees. The dip direction indicates it is dipping 103 degrees, so toward the east. 

Step 5
Go back to your hypotheses on Days 2 and 3, with particular attention to the testable hypotheses you listed in Sheep Draw. Develop a protocol for measuring either distances, angles, or both, that will answer a hypothesis. Be sure to restate what hypothesis you are testing. Take at least three measurements to support or refute your hypothesis. 
Area of Interest Studying:
Hypothesis: 
Protocol: 
Measurements: 
Hypothesis supported or refuted? Why?:
Also include an image of your area of interest that shows how you are measuring your feature.

Step 6
Discuss other geologic, ecological, or engineering applications where a point cloud and tools available in CloudCompare would be useful to address a research project. Write at least five complete sentences. 

Part 2: Classification with CANUPO
With the use of CloudCompare, hopefully you were able to explore visual and quantitative assessments about your point cloud. However, without classification, we cannot do much with the point cloud. To make a digital terrain model (DTM), or digital elevation model (DEM), we need ground points separated from vegetation points. Likewise, if we were interested in vegetation (e.g., canopy model), we would also need the vegetation classified. 

With airborne LiDAR, multiple returns are registered by the instrument. Because it is administered from the top down (from an aircraft), airborne LiDAR receives a first return that hits the top of the canopy, and a last return that is likely to be a ground point. As such, with airborne LiDAR, last returns can be isolated to form a ground model. For SfM and TLS, a separation based on returns is not possible, thus, a different method of classification has to be used.  
Luckily, an open-source classification is included as a CloudCompare plugin called CAractérisation de NUages de POints (CANUPO).http://nicolas.brodu.net/en/recherche/canupo/ 

In short, CANUPO takes advantage of the “signature” of different features across scales and in 1D, 2D, and 3D.
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We will classify our point clouds by working through the instructions outlined here: https://www.cloudcompare.org/doc/wiki/index.php?title=CANUPO_(plugin) 

Step 1: Subsample Classes
Reimport or recombine point clouds in CoudCompare. The first step in classifying with CANUPO is to cut out examples of each class. Use the cut tool 
[image: ] to cut out an example [image: ] Click the green check mark if you are happy with your result. Repeat to have several subsamples of the feature you are attempting to train the classifier to identify. For example, tall vegetation, as I have done below. When you have subsamples of the class (e.g., vegetation), recombine the clouds for that class into one using the recombine tool (you may have to repeat until all are combined into one cloud). 
[image: ]
Repeat Step 1 for ground class.
[bookmark: _GoBack]Rename these clouds with the appropriate classes (“Vegetation” and “Ground”) by double clicking the cloud. 

Step 2: Create a Trained Classifer
Go to the Plugins menu for the top dropdown menu. Plugins >> CANUPO >> CANUPO Training 
From the Data dropdown menus, change class #1 and class #2 to correspond to your subsampled clouds. Go ahead with the defaults and save a classifier (.prm).

Step 3: Classify the Cloud
Go to the Plugins menu for the top dropdown menu. Plugins >> CANUPO >> CANUPO Classify. Navigate to your saved .prm file and make sure the cloud you want to classify is selected. Also notice that to classify the entire cloud, you have to recombine the whole cloud or reimport the cloud if you don’t want to lose the work you did subsampling the different regions. 
Click OK.
[image: ]

Step 4: Filter Points by Value
If you are satisfied with the result, you can filter the point by the scalar field (classification) by using the “Filter points by value” tool.
[image: ]
Select the range of scalar values corresponding to the “ground” points in this case. 
[image: ]

Change the color back to RGB and inspect the cloud. 
[image: ]
In my case, I have a couple spurious high points corresponding to vegetation. 

Step 5: Clean up Final Ground Cloud
Clean up the resulting cloud by attempting an additional classification or simply cutting out spurious points. You could also try the Tool menu from the main dropdown: Tool >> Clean and try a filter. Make sure to grab a screenshot or snip of your cleaned pointcloud.
Step 6: Export Ground Cloud
Save your final ground cloud my File >> Save and choose ascii as the format. Note, you could also save as .las if you are familiar with that (las is a format used often for airborne lidar).
[image: ]
Step 7: Create Digital Terrain Model from Ground Points
From here, you have a number of options for gridding the points to create a rasterized version (e.g. digital terrain model or digital elevation model). We will use CloudCompare’s rasterize tool. This will create a 2.5D model, meaning a rasterized version of the data from a top-down view. Each raster cell will have a value corresponding to the elevation when we are done. This is, in effect, a digital terrain model (DTM) or a digital elevation model (DEM). 
From the main dropdown menu, choose Tools >> Projection >> Rasterize. For the cell size, you could pick something like 0.1 m (10 cm) or larger if your computer is struggling to process the point cloud thus far. For Projection Direction, pick Z. For cell height, you can choose minimum if you had a little vegetation noise left in your cloud. This will choose the minimum elevation value in the cell. Otherwise, you could choose average to take an average of the points within the cell. Click “Update Grid” and you will see a preview. 

[image: ]

In the Export panel, you can export the raster with the min or average (whichever you choose) value of the points within the raster window. There are tabs for Contour plot, Hillshade, and Volume. Start with the Height grid values as your active layer and click “Raster.” Notice choices for exporting, including the RGB colors, heights (elevation), scalar fields, and density. For now, just choose “Export heights.” Note: you could export the entire point cloud with a field associated with the CANUPO Class. This would be useful if you were interested in keeping the entire cloud or looking at the vegetation for some reason (in this case we aren’t).
Also export a Hillshade. Click the Hillshade tab and click “Generate” to preview. Hillshades allow your eye to see elevation in a more 3D view than a simple color scale with elevation values. You can easily make a hillshade in ArcMap/Pro as well, which we will do later. 

Step 8: Work with Rasterized Version of Point Cloud
We now have a rasterized version of our point cloud we can work with in a program such as ArcMap, which we will do next. 

To Turn in:
Your measurements and answers from Part 1
Step 5: Go back to your hypotheses on Days 2 and 3, with particular attention to the testable hypotheses you listed in the Sheep Draw SfM exercise. Develop a protocol for measuring either distances, angles, or both, that will answer a hypothesis. Be sure to restate what hypothesis you are testing. Take at least three measurements to support or refute your hypothesis. 5 pts
Area of Interest Studying:
Hypothesis: 
Protocol: 
Measurements: 
Hypothesis supported or refuted? Why?:
Also include an image of your area of interest that shows how you are measuring your feature.

Step 6: Discuss other geologic, ecological, or engineering applications where a point cloud and tools available in CloudCompare would be useful to address a research project. Write at least five complete sentences. 3 pts 


Answers related to Part 2
Answer with complete sentences. 3–5 sentences each prompt. 2 pts each
1) How well did CANUPO classify your point cloud? Compare and contrast it to the classification tool in Metashape? Pros and cons of each? 
2) In the rasterization step, did you choose the minimum or average cell value? What was your rationale for your choice? 
3) What were the strengths and weaknesses of your SfM model and associated raster? What was captured well/not well? 
4) Given the quality of your final model, what do you think you could use it for? 




CloudCompare Rubric - Working with Point Clouds in CloudCompare; classifying with CANUPO
This rubric covers the material handed in for CloudCompare student exercise and is the summative assessment for the unit. 

	Component
	Exemplary (75-100% points)
	Basic (50-75% points)
	Minimal effort (25-50%)
	Nonperformance (0-25%)

	General Considerations
	Exemplary work will not just answer all components of the given question but also answer correctly, completely, and thoughtfully. Attention to detail, as well as answers that are logical and make sense, is an important piece of this. 
	Basic work may answer all components of the given question, but answers are incorrect, ill-considered, or difficult to interpret given the context of the question. Basic work may also be missing components of a given question. 
	Minimal performance occurs when students answers simply do not make sense and are incorrect.
	Nonperformance occurs when students are missing large portions of the assignment. 
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