Exercise 8d: Hamilton College well data
Due: Friday, April 22 at the beginning of class.

Goal: to download the GPS data from your Garmin unit and create a shapefile with all of your Hamilton College well data.
Turn in: nothing. Just have your well data ready to go on Friday.
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You will learn the following techniques:

· downloading data from a GPS unit and creating a shapefile.

· drawing a line in a specific direction for a specific distance; going to a specific X-Y coordinate and adding a point.

· editing a shapefile, including adding a point with coordinate values, deleting a record, adding fields (and determining field type, precision and scale), calculating geometries, and doing calculations using the Field Calculator. 
· extracting values to points (e.g., determining the elevations of points in a shapefile using the elevation data in a raster data set).

 Part I: Downloading your GPS data from the Garmin unit 
A. Transferring GPS data from your Garmin eTrex to ArcMap
1. Be sure that the GPS is not showing a “low battery” message. If the batteries are low, replace them before proceeding. You won’t lose your waypoint data while you’re replacing the batteries.

2. Connect the cable between the com1 port on the computer and the GPS. These cables only fit eTrex units.

a. Turn on the GPS unit and allow the main screen to come up

b. Start ArcMap, open to a new map, or any .mxd file. ArcMap must be open in order for DNR Garmin to save a shape file directly. [If you are working on a computer that doesn’t have ArcMap on it, you can still save a shape file via File > Save to > File, and setting the pulldown under file type to Shape File.]

c. Launch the DNR Garmin application. You should see Connected in the lower left corner of the application window. The Projection may be different than shown in the picture below.
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d. If the GPS and computer are not talking to each other, check under GPS to make sure that Set Port > Port 1 and Set Baud Rate > 9600 (Garmin default) are set correctly. The other place to check is that the interface on the GPS unit is set correctly (on the GPS unit  Main Menu > Setup > Interface > Garmin).  You can also try clicking on Open Port.

B. Setting the projected coordinate system to transform the data
1. All GPS data are collected in WGS84 (World Geographic System 1984) coordinate space. DNR Garmin can transform these data to a PCS as the data are downloaded. 

2. The correct PCS must be set prior to downloading the GPS data. In the main DNR menu, File > Set Projection. What coordinate system do you need to match the work you’ve done so far with your LiDAR data?
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3. The DNR Garmin Properties window opens. Set the datum pull-down to the coordinate system you need. If there is nothing in the PRJ DEFINITION box, click the LOAD PRJ button, and browse to the CS that you want. To find the projection options, you need to locate the Coordinate Systems folder in ArcGIS on the C:\ drive of your computer. On the GIS lab computers, it will be C:\ProgramFiles(x86)>ArcGIS>Desktop10.0>CoordinateSystems. Don’t click OK until you have the correct projection listed in the PRJ DEFINITION box.

4. The correct projection should show next to the Connected field.
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C. Download the waypoints
1. Go to Waypoint > Download.
2. [image: image9.jpg]


 The waypoints download, and you’ll see a window that shows the total number of waypoints downloaded. If the table of waypoints does not show, click the >>>Data Table>>> button to expand the window.
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3. DNR Garmin creates an extensive number of fields associated with each waypoint to take advantage of all the data that can be entered on various Garmin units. Most of these data fields are not applicable to the eTrex units that we have and simply get in the way. To minimize the number of fields created, go to Waypoint > Waypoint Properties in the main DNR menu, and uncheck all boxes except type, ident, lat, long, y_proj, x_proj, and altitude and click OK. These settings will remain in DNR Garmin until changed, or reset using the Reset button in Waypoint Properties.

D. Saving a projected shapefile for use in ArcMap
1. In the DNR Garmin menu, choose File, and save as an ArcView Shapefile (Projected).
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Part II: Creating a shapefile with all of your wells accurately located 
A. Creating a file with all of your wells accurately located

1. Start by making a copy of your wells shapefile, and give it a name to make it clear that one is the original data and one is your working file. You’re going to make some changes to the shapefile, and you want to make sure that you can always get back to your original data if you jack something up.

2. Launch ArcMap, and add your LiDAR bare earth first. What coordinate system will your data frame be in, and what will the units of measure be?

3. Then, add the orthophotos and the working copy of your wells shapefile. Check to see if your wells plot where you think they ought to plot. If all of them are off by an equal amount, you may have used the wrong coordinate system. Go back and double-check the coordinate systems on all your files and fix the errors before proceeding. If some are clearly off and others are OK, you will have an opportunity to fix the badly located ones below.

4. To add a point for an additional well that you did not locate in the field: 

a. You have the following coordinates for an additional well:

longitude: 467230.729753            latitude: 4766691.134605

b. What kind of coordinates are these, and what units are they in? 

c. Select the Go to X-Y tool from the regular tools menu (cyan square with X-Y under it). Select the correct units from the pulldown menu, type in the coordinates, and click the Add point icon (the cyan square). Click FLASH, if you can’t find your point.

d. Start editing, and add a point at this location to your wells point shapefile.
e. Open the Attribute table for your wells layer, and you will see that the newly added point does not have coordinates associated with it. Because your map is in a projected coordinate system, you won’t be able to update the lat/lon fields, but you can fill in the Y_proj and X_proj fields (the projected coordinates).

a. Select the line of data with the new point. Remind yourself. Is the Y coordinate the latitude or the longitude?

b. Right click in the Y_PROJ header field and scroll to Calculate Geometry. [Note: this can be done either in an edit session or not. Read the warning that comes up when doing this outside of an edit session to decide if you want to use an edit session or not. Click Yes if you want to work outside of an edit session, or No to cancel. If you cancel, start an edit session and then proceed.]
c. In the Calculate Geometry dialog box, select Y Coordinate of Point from the pulldown menu. Under Coordinate System, the coordinate systems for the source and for the data frame should be identical. Click OK.
d. Do the same for the X_PROJ column, being sure to select the X Coordinate of Point from the Property pulldown. If you are working in an edit session, stop editing and save your edits. Double-check to make sure that the numbers in the Y and X columns make sense. If they are both the same, you forgot to select the correct coordinate in the Property pulldown. 

e. Write down below what it is that ArcMap just did and what the numbers in these two columns represent:
f.  Delete the point that you added with the Go to X-Y tool.
5. Correcting well locations by inspection:

a. We have high resolution air photos of the campus, and it may well be that locating some of the wells can be done more accurately by inspection of the air photo than by using your field GPS readings. If you have any wells that are poorly located, you can add a new, and better-located, well point.
6. If you need to plot a well that has an offset GPS reading (you may or may not have one of these).
a. Create a new line shape file and add it to your ArcMap. 

b. Start editing, and select your line shape file to edit. 

c. Under Editor > Options > Units, be sure to set the Direction type to North Azimuth and the Direction Units to Decimal Degrees.

d. Left click on the GPS point you established as the offset point, and start dragging a line segment towards the wells. As you are dragging the line, rt-click, and a pop-up menu will appear. Choose Direction, type in the compass bearing, and press Enter. Rt-click again and enter the distance from your GPS point to the well head. Press the Enter key, and the line will extend in the direction and length specified and end in a red square. The cursor will allow you to add an additional line to this segment, but you do not want to. Instead, move the cursor over the red square, and double click to finish the line (or right click, and choose finish the line.  The end of the line indicates the location of the well.
e. Note that there was no opportunity to specify units for either direction or length. What units will ArcMap assume you have entered in the direction box, and why? What units will ArcMap assume you have entered in the distance box, and why?
f. Save your edits. 
g. Switch to edit your wells shapefile, and add a point at the end of the line to correctly locate the well. Calculate geometry to add the coordinates. Stop editing, and save your edits.
h. Delete the point that marks where you took the GPS reading for the offset GPS. You can find this easily by starting an editing session, and clicking on the point with the Editor selection tool. The line highlights in the attribute table. Rt-click and choose Delete selected. Save your edits.

When you’re all done, you should have 9 wells in your attribute table.
B. Adding the rest of the well data to your shapefile

1. Elevation data for each well
a. You’ll need an elevation value at each well so we can figure out the elevation of the water surface below the ground. The elevation data that you collected with the GPS unit is not particularly accurate for what we need to do for two reasons: 1) it reflects the position of the GPS unit, which was not the actual top of the well casing or the ground surface, because you were holding it in your hand, not placing it on the well cap or on the ground; 2) the elevation data from a handheld GPS such as this isn’t particularly good. 

b. We have excellent elevation data in the LiDAR DTM – the vertical accuracy is 0.36 m (much better than the GPS!). You could zoom in to each well and then use the get info tool to view the elevation data of the LiDAR pixel associated with the well, but there is an easier way to get the ground elevation information at each of the well locations. 

1. Using the Extract Values to Points tool, you can add the elevation data contained in the LiDAR DTM at each well to the well shape file attribute table.

2. Run the tool, figuring out for yourself what to use as input and output. Read the help menu if you’re unsure of which decisions to make. 

3. Open the attribute table for the new shapefile, and you’ll see a new field called RASTERVALU. What do these numbers mean, and what are the units? How do you know?

2. Water table data for each well

a. We know the ground surface elevation at each well, the height of the casing, and the water depth below the top of the casing. Write a formula below that will give you the elevation of the water table in each well.

b. You will need to add four new fields to your new wells shapefile (the one with the well elevations) so that you will have all the items you need with respect to your formula: 

· casing height (if you measured this in the field in cm, you’ll need to convert to m)

· depth to water in well from the top of the casing, which we have from Todd in integer feet (no decimals or fractions of a foot).
· depth to water in meters from the top of the casing, which you will ask ArcMap to convert from feet

· water surface elevation, which you will ask ArcMap to calculate based on the parameters in your attribute table

4. For each of the new fields, you will need to decide on Field Type, Precision, and, for some field types, Scale as well. Use ArcMap Help 
5. to figure out what these terms mean and which choices to make for each of the fields. Check with us about your decisions before going on:

	Field
	Field type
	Precision
	Scale

	Casing height (in meters)
	
	
	

	Depth to water
	
	
	

	Depth to water
	
	
	

	Elevation of water
	
	
	


6. Add the four new fields to your attribute table, with the correct parameters.

7. Start editing, and add the correct casing height (converted from cm, if necessary) and the water depth in feet (see list below):

Water depths in the wells are:

Science Center: 11 feet

Science Center: 11 feet

Soccer field: 4 feet

North: 8 feet

Kirkland: 8 feet

1891 rock: 1 foot

1891 rock: 1 foot

Upper cemetery: 1 foot

Lower cemetery: 2 feet (and a casing height of 103 cm)
8. Save your edits. To convert these measurement to metric, right click in the heading of the water depth in meters field and scroll to field calculator. In the field calculator, enter a formula that will convert feet to meters. Check your formula with us. Save your edits.

9. Use the formula that you wrote in 2a above, and enter it into the field calculator for the water elevation column. Your water elevation field should now be populated. 

10. Before going any farther, do the numbers make sense? Write your Quality Assessment (QA) below:

11. Stop editing, save your edits, and save your ArcMap.
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