Exercise 2c: Exploring coordinate systems & projections

Data sets downloaded in homework Ex. 2b: 
· Westernville and Clinton, NY orthoquad, DEC topo tiles, and DEM
· NY State Faults
· SRTM DEM of central NY
· Orthophotos of Hamilton College


Due: Part Weds, Part Fri (see below); URLs by email by Tuesday at 5 pm.
Goal: 1) to explore geographic and projected coordinate systems; 2) to learn how to handle coordinate systems in ArcMap, including defining a coordinate system/projection for a data set with an unknown spatial reference and changing the coordinate system/projection both by permanent datum transformation and/or reprojection and by making the change “on the fly” without altering original data.
Turn in: this sheet with the answers to the questions (Weds., Sep. 5) plus one well-crafted ArcMap as an exported jpeg or pdf file that illustrates a major point that you learned from this exercise (details at the end of the exercise) (Fri. Sep. 7).


Part I. Geographic vs. projected coordinate systems
We’ll start by making sure that everyone is clear on what coordinates are and what a coordinate system is, and we’ll work through the differences between geographic coordinate systems (GCS) and projected coordinate systems (PCS). We’ll address any questions that you have about the reading on projections. 

Part II. Working with coordinate systems in ArcMap
As we work through some examples in ArcMap, realize that the terminology can be confusing and that the terms “project” and “projection” are commonly used very loosely and generally to refer broadly to all coordinate systems and to operations in both geographic and projected coordinate systems. 

· ArcMap uses the file suffix “.prj” for all spatial reference files, regardless of whether the file is for a geographic or a projected coordinate system. 
· ArcMap operations for defining a spatial reference or changing an existing reference are called Define Projection, Project Feature, and Project Raster, regardless of whether you’re dealing with a geographic or a projected coordinate system. And even if you want to choose WGS84 in the folder of Geographic Coordinate Systems, the choice is WGS84.prj, even though the choice does not actually project the data.
· And many people just use the terms casually – “what’s the projection for that data set?” might be a question that someone asks, regardless of whether they’re talking about GCS or PCS. 

So, part of what we’ll do in this exercise is help you keep track of the distinctions and make the right choices when you’re working with data. 
A. Using ESRI ArcGIS Online to find data
1. We’re going to start by searching for a data set in an extensive ESRI online data source that can be accessed directly from either ArcMap or ArcCatalog using the Search tab. 
2. [image: ]Launch ArcMap and start a blank ArcMap. If the Search tab doesn’t show on the right, click the Search icon in the main menu bar to bring up the search window, and dock the Search window on the right. 
a. Open the Search window, and choose ArcGIS Online from the pulldown. This will allow you to search ESRI’s online set of maps and data. Be sure that All is selected.
b. You’re looking for a shapefile of the world’s continents – just outlines, nothing fancy. Try typing the word continents into the Search box, and see what you find.
c. The yellow diamond icons contain data sets that can be added to ArcMap; the square icons are web maps (which you don’t want). Choose the World Continents file.
d. Let’s see where ArcMap put the files when you added it to ArcMap. For your continents layers, get the Properties, and choose the Source tab. Under Database, you’ll see the location where the file is stored on your hard drive. Where did ArcMap store the file? Write the pathname below.




e. You actually want to have the file stored on your portable hard drive in a folder along with the other parts of this project. You could track it down in the default location on the C:\ drive and move it, but it’s simpler to just Export the data to a new layer in ArcMap and delete the old one. To do this, right click on the layer, Data > Export Data. Export all features and choose this layer’s source data. Browse to where you want to store the file, and select Shapefile from the Save as type pulldown. Later in the semester, we’ll learn how to use the Geodatabase format that is the default.

[image: 2c-II-A-2f]

f. Click Save and OK, and Say yes to add the exported data to the map as a layer. Delete the original file (s). Pretty slick, huh?
g.  For your new exported continents layer, change the symbology and labeling to make each continent a different color and to have each continent labeled with its name.  




1. Note: the Export Data operation simply copies the file from Documents to a new location – it doesn’t actually delete it from your Documents inside the Users folder. You can imagine that, if you download enough data, you could wind up with a boatload of unwanted files buried deep in Documents. It’s easy to be ambushed by this, because it looks like all that’s happening is you’re adding a data layer to an ArcMap when you click on the link. If you add something and then decide that you don’t really want it and just deleted it from your ArcMap, it’s still there in buried deep inside the Documents folder. You should get into the habit of periodically purging the default Save location of stuff you’ve downloaded from ArcGIS Online.

B. Finding metadata 
1. Launch ArcCatalog as a standalone application. We’re going to look at file metadata, and you can’t look at file metadata in the view of ArcCatalog that you can see when you’re in ArcMap.
2. Before you can look at the metadata for your files, you will need to change from the default “Limited Description” metadata to show the extensive metadata that we want to see. This is another one of those things that you need to change again if you use a different computer or after the lab computers are re-imaged.
a. In the main menu bar, Customize > ArcCatalog Options.

[image: ]

b. Under the Metadata tab, choose FGDC CSDGM Metadata from the pull down menu. This adds this style to the existing Item Description under the Description  tab.

[image: 2c-II-B-2bf]

c. Refresh the ArcCatalog Tree. 


[image: ]
2. Highlight the continents shapefile in the ArcCatalog CT. Click the Description tab above the main ArcCatalog window, and you will see ArcGIS Metadata. Under ArcGIS Metadata, go to Spatial Reference.
  
Does the continents shapefile have a PCS or a GCS? How do you know?



What is the ellipsoid/spheroid? the datum?


Are the units in meters or degrees?


3. Examine the metadata for either of your DOQs.
Does the orthoquad file have a PCS or a GCS?


What is the spheroid/ellipsoid? the datum? the projection?


Are the units in meters or degrees?


4. You can also check the spatial reference information for a data set by right clicking and getting Properties and finding the spatial reference or XY coordinate system information. Do this for your nyfaults file that you downloaded from the server. What did you find about the coordinate system? 




C. Exploring coordinate systems 

1. Start a new ArcMap, and add your nyfaults shapefile first. Click OK when the warning box comes up. Now add your continents shapefile. Save your .mxd file.
2. Zoom to the continents layer (rt-click > Zoom to Layer). If ArcMap did the job that you hoped it would, you should be able to zoom in to New York State and see the faults in the right place. Rearrange the layers, if you need to, in order to put the faults on top of the continents layer. Are the faults where they should be? Zoom-to-layer for the faults layer. Where is it?



3. Add a new data frame to your ArcMap (Insert > DataFrame). Activate the dataframe by rt-clicking on the new data frame in the TOC and selecting Activate. This time, add the continents file first, and then the faults file. Rearrange the layers so that faults are on the top, if you need to. Are things any better?



4. Now add the Westernville orthoquad to each of the dataframes (be sure to first activate the dataframe before adding the data). Again, ignore and close the warning boxes. OK build pyramids. Rearrange so that the DOQ is the top layer in each dataframe. Use Zoom to layer to see where the DOQ is in each of the dataframes. Wow! What happened?



5. Get the Properties for the first dataframe, and click the Coordinate System tab. What is the coordinate system of the first dataframe? 



6. Do the same for your second dataframe. What is the coordinate system of the second dataframe? Why are they different?



So, why the very different behavior for the orthoquad?? ArcMap did the best it could with the limited amount of information it had about the faults shapefile. It had numbers associated with the faults file, although it didn’t know what they meant. So, when you added the continents shapefile to the first dataframe, ArcMap assumed that the units were the same. If the faults file was a projected file with X and Y in meters, numbers would have been in the hundreds of thousands to millions. On the other hand, the degree values for X and Y for the continents file would have been much smaller numbers. They would have plotted in vastly different places in X-Y space! 

So, why did the orthoquad show up with the faults file in dataframe 1 and with the continents shapefile in dataframe 2?




Important take-home messages:
· Don’t ignore warning boxes. I asked you to ignore them above to make a point, but you shouldn’t ignore them in the future!!!
· The dataframe will adopt the coordinate system of the first layer that is added. No amount of rearranging will change that. And if you delete the original layer hoping to solve the problem, it won’t work. The data frame still retains the coordinate system (or lack thereof) from the original layer added. The coordinate system may be either a GCS or a PCS.
· A dataframe cannot have more than one coordinate system. On the other hand, an ArcMap can have more than one dataframe, and each data frame can have a different coordinate system.
· If the coordinate systems of two data sets do not match, ArcMap will try to project a data set “on the fly” to the coordinate system of the dataframe (i.e., the coordinate system of first layer added). If the coordinate system of the dataframe or a layer to be added is undefined, ArcMap can’t do this correctly, and data sets added to such a data frame typically appear to have vanished.


D. Defining a coordinate system for a data set that doesn’t have a spatial reference (also called defining a projection).
1. Start by mosaicking together two of the DEC tiles that you downloaded from our course Data folder for the Westernville quad. 
a. In ArcCatalog, go to ArcToolbox > Data Management Tools > Raster > Raster DataSet > Mosaic to New Raster.  Click the “Show Help” button if the tool help bar isn’t showing at the right.
b. In the Mosaic dialog box, input tiles o4679c and 04579d by clicking on the folder and browsing to the first file or by drag-and-drop. Click the + button, and repeat for the second tile.
c. Browse to an output location by clicking on the folder. Remember that you are selecting a folder to put the mosaic in, not naming the new mosaic.
d. In the next line, type a name for the mosaic. Short, no spaces.

[image: 2c-II-D-1d]

e. Type 1 into the bar under Number of bands.
f. Scroll down to the Mosaic Colormap Mode. Although this is optional, you should make a choice here, because the colors will be screwy otherwise. Here’s a good time to learn how to use the Tool Help bar to help you. Click in the text bar below Mosaic Colormap Mode. This will bring up the help for that setting. Read through the choices, and pick the one that is most likely to produce a good mosaic if you can’t be sure that all the possible colors are present on one of the tiles. Click OK, and Preview your mosaic. If it doesn’t look good, try again.

[image: 2c-II-D-1f]

2. Start a new ArcMap. Don’t just delete layers! Close any existing .mxd files, and launch ArcMap again. Why shouldn’t you just delete the layers from your continents/faults .mxd and add new stuff to that map? Why bother to create a brand new map??







3. Add your Westernville DEM. Create a hillshade. Save your .mxd file.
4. [image: 2c-II-D4]Add your new mosaic, and this time do not ignore the warning dialog box that comes up. Leave it up on the screen, and answer the following question. What does the dialog box mean?









5. This file is missing the information on its coordinate system – either the .prj file is missing, or ArcMap isn’t recognizing the .prj file. In order to properly place the file, you must tell ArcMap what coordinate system this file is in. You will do this by defining the projection (again remembering the terminology that this might actually mean defining a GCS or a PCS).
6. Well, what coordinate system might these tiles be in? You might reason out that the topo tiles ought to have the same coordinate system as the full orthoquad that you downloaded from the NYSGIS clearing house (they certainly look the same). It might also be logical to think that the topo tiles might have the same coordinate system as the DEM from CUGIR, because the DEMs were generated by scanning the original USGS topographic quadrangle maps (remember the metadata that we looked at in class for NYS DEMs?). 
7. Click OK in the warning, box, and then delete the offending layer from your ArcMap (you can’t make a change in ArcCatalog with the layer open in ArcMap).  Go back to Arc Catalog. 
a. What coordinate system is your Westernville DEM in? 



b. How about the collared orthoquad (the Westernville DOQ) that you downloaded from the NYSGIS Clearinghouse?



8. Well, that’s consistent. Both are in NAD27 UTM 18N. So, let’s define the projection for your mosaic to match the other two. 
a. Start by making a copy of your mosaic, and add NAD27 to the name (you may need to change the existing name to make it short enough if it fails to rename).
b. Go to ArcToolbox > Data Management Tools, Projections and Transformations > Define Projection.
c. Click the folder icon, and browse to your mosaicNAD27 file. Click the icon to the right of the Coordinate System line to bring up the Spatial Reference Properties dialog. Which folder do you want, Geographic Coordinate Systems or Projected Coordinate Systems? Why?




[image: ]

[image: ]
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d. Open Projected Coordinate Systems > UTM > NAD 1927 and select NAD 1927 UTM Zone 18N.prj. Before you click OK, check to make sure you have actually selected the right coordinate system name. Click OK, and OK.
e. Go back to ArcMap, and add your new mosaic with its defined projection. Save. Make sure the mosaic is at the top, and increase the transparency so that you can see the hillshade below. Zoom in, browse around, and look carefully at the registration (e.g., of the edges of the lake or the valleys).  OH NO! What happened??? 



f. Use the measure tool to determine approximately how much offset there is in the NS and the EW direction. A good place to do this is on the north side of Delta Lake.

NS offset:                                                       EW offset:

g. Well, clearly we fouled this up. If we had picked the correct coordinate system, the topo tiles should have lined up with the hillshade. Just to convince yourself that this is the case, add the NYSGIS orthoquad, and check to see if it lines up with the hillshade or not. Does it?




8. We obviously made a bad assumption about the actual coordinate system for the CUGIR DEC tiles. So, what do we do? We need to find out what the coordinate system really is. Fortunately, the CUGIR site (and most reliable sites) actually have the metadata on their websites. The following page on the CUGIR site, https://cugir.library.cornell.edu/catalog/cugir-009001, contains information on the coordinate system for CUGIR’s New York State USGS topographic map products. What did you find out about the coordinate system?



9. Go back to ArcCatalog, and make another copy of your mosaic, adding NAD83 to the name this time. Define the projection again, this time using NAD83 UTM 18N, instead of NAD27. Add your new file to your ArcMap. OH NO! Another dialog box!! This time, ArcMap is telling you that the Geographic Coordinate Systems don’t match (screen shot below). What does this mean, and why don’t they match?






10. Again, we’re not going to ignore this dialog box. ArcMap needs to make a datum transformation in order for the new layer to line up with the DEM and the orthoquad, which both use the older NAD27 datum.
a. Although ArcMap will happily do a datum transformation using a default setting, it is best practice to choose a transformation for ArcMap to use so that you get the best results.
b. Click on Transformations. In the next two dialog boxes, choose Convert from NAD83 into NAD27.  In the pulldown, you will see a list of possible transformations to choose from. Realize that a transformation is good in both directions (i.e., you can use the NAD27 to NAD83 NADCON transformation to transform NAD27 to NAD83 or vice versa). Look in your list of Geographic (Datum) Transformations and choose the one that best fits your data set. Which did you choose, and why?


[image: 2c-II-D-10]

c. Click OK, and close. ArcMap does the transformation for you. Does your mosaic line up this time? Hot diggity! That’s pretty swell.
Important take-home messages for files that are missing a spatial reference:
· Don’t ignore warning boxes (do I sound like a broken record??). 
· If a file is missing a spatial reference, you must define the projection (remember, of course, that “projection” is used somewhat loosely here and could refer to defining either a GCS or a PCS).
· You cannot simply choose the coordinate system that you want the data to have. You MUST define the actual coordinate system that belongs to the data. If you do not know what that is, you must find out (e.g., from the clearing house where you downloaded the data). If you can’t find out, there are a few strategies that are better than the lame one we used in the example to try to figure out the likely coordinate system. We’ll get to those later.

Important take-home messages for datum transformations:
· For best results, make a deliberate (and correct!) choice for the datum transformation. There’s commonly more than one transformation to choose from for a given coordinate system, and the choice is commonly not as obvious as NADCON. Use the spreadsheet that I’ve given you to help you choose the correct transformation for whatever part of the world you’re dealing with. If you ever lose this spreadsheet, you can download it again at:

http://desktop.arcgis.com/en/arcmap/latest/map/projections/pdf/geographic_transformations.pdf 

E. Changing the coordinate system of a set of data with a defined coordinate system to a new coordinate system (also known as projecting a raster or projecting a feature).
1. Preview your three orthophotos of Hamilton College in ArcCatalog. 
a. What is the coordinate system for the image starting with “c”? What are the units?




b. What about the two images starting with “ClintonSE”? What are the units?




2. We’re going to make an ArcMap with these images plus the Clinton DOQ from the NYSGIS clearing house. We’ll convert the DOQ from NAD27 to match the more recent (and more accurate) datum of NAD83 for the orthophotos, rather than vice versa.
3. We don’t need to make a copy of the Clinton DOQ first, because the projection process creates a new file (unlike the Define Projection process, which changes the original file).


4. [image: 2c-II-E-4]In ArcCatalog, we will make a new Clinton DOQ with a coordinate system that matches the orthophoto with the “u” number (which is in NAD83 UTM 18N). Because the DOQ already has a defined coordinate system, we do NOT use the Define Projection tool that we used in D above. Instead, we use the Project Raster tool.
e. In ArcCatalog, go to ArcToolbox > Projections and Transformations > Raster > Project Raster. Input your Clinton DOQ, and change the name of the output raster to something shorter and involving NAD83 so that it’s easy to see which file is changed. Do this by using the folder, not just typing into the text bar.
f. Click on the coordinate system icon, and choose Projected Coordinate Systems > UTM > NAD83 > UTM18N. Check that you’ve chosen the right one before OKing the dialog box.
g. Choose the correct Geographic Transformation (you’re changing from one datum to another).
h. Scroll down to Resampling technique. NEAREST is fine for resampling a data set such as an orthoquad. If, on the other hand, you were resampling continuous data (such as elevation data on a DEM or pixels in an orthophoto), you should choose BILINEAR.
i. Click OK.
7. Start a new ArcMap, and add the NAD83 Clinton DOQ. Add the two ClintonSE images. You shouldn’t get any warning boxes if you’ve done everything correctly. Zoom in, and check to see if everything lines up well. Save your .mxd file. We’ll use it again for the next part of this exercise.

Important take-home messages for converting coordinate systems:
· Don’t ignore warning boxes (do I sound like a broken record??).
· Do not use Define Projection to convert a data set from one coordinate system to another. Define Projection is only for setting the coordinate system for files with unknown spatial reference (see Part D above).
· Use Project Raster (for raster files) and Project Feature (for shape files) to convert a data set from one coordinate system to another. Remember that these tools are also used to convert geographic coordinate systems to other geographic coordinate systems, even though “projection” is not involved.
· It is best practice to have all your data in the same coordinate system before starting a project, rather than having ArcMap project on the fly. 
· It is also best practice to convert files in older coordinate systems to more recent ones that are the most accurate for the area in question.
· [bookmark: _GoBack]Re-projecting data more than once degrades the data. Indicate somewhere in the file name what the new coordinate system is so that you know which are your original files. If you need to convert again, start with a new copy of the original data, not with one of the re-projected files.
F. Changing the coordinate system of a set of data to a new coordinate system temporarily “on the fly”
1. Add the original Clinton DOQ (in NAD27) to your ArcMap from the previous section. You should get a warning dialog box. Make the appropriate choices for the datum transformation (as you did in part B). Click close, and ArcMap adds the re-projected DOQ to the map.
2. This is what’s known as projection “on the fly”. This is a temporary re-projection that does not change your original data file. 
3. Now, add the other HC orthophoto (the one with the “c” number. Does its coordinate system match the one with the “u” number?


4. But you didn’t get a warning box! Because both are in NAD83, no datum transformation was involved, just a re-projection from UTM to State Plane. ArcMap just did this on the fly without warning you. Check to see if the two photos line up well – they should.
5. And one last thing. Add a new dataframe, activate it, and add your original Clinton DOQ (the one in NAD27) to that dataframe. Remember that a dataframe has the coordinate system for the first layer added to that dataframe, so one data frame is in NAD83 and the other is in NAD27.
a. Activate the NAD27 dataframe. Zoom in until you can see the symbol for the Science Building (remember that this is an old map, so it won’t have the whole new Sci Center). 
b. What are the UTM coordinates for our classroom in the NAD27 datum?


c. Now activate the NAD83 dataframe. Zoom in on the Science Building symbol. What are the UTM coordinates for our classroom in the NAD83 datum?


d. How much different (in meters) is the northing? How about the easting?


e. Then, go to Google Earth. What are the Google Earth UTM coordinates for the same spot? What datum does Google Earth use?



f. Remind me that you know why the coordinates are different in NAD27, NAD83, and WGS84.






G. And a little fun with projections
1. Start a new ArcMap, and add the continents shapefile.
2. Add several new dataframes. Remember that to change a dataframe name or to add something to a dataframe, you need to activate it (rt click > Activate).
3. We’re going to take advantage of projecting on the fly to do a little experimenting with projections. By projecting on the fly, you won’t clog up your folder with new shapefiles.
4. Activate the first new dataframe. If we set the projection of the dataframe, and then add the continents shapefile, ArcMap will project the continents on the fly and display it in the new dataframe.
a. Right click on the new dataframe name, and select Properties. Choose the Coordinate System tab > Predefined > Projected Coordinate Systems.
b. Use the list of map projections in the handout, or just try out one that sounds interesting in the list on the screen. Rename the dataframe to reflect the projection name.
c. Add the Continents shapefile to your new dataframe. ArcMap projects it on the fly! But remember, your original data are not modified, and there’s no new shapefile in your folder. If you want to make the projection permanent, you need to use ArcToolbox, and Project Feature (not raster, because this is a shapefile) to create a new, projected shapefile. You can also make the projection permanent by exporting the data from the TOC and choosing the Data frame coordinate system, rather than the source data for the layer.
d. Try out at least 5 or 6 other projections, trying some that are global, some that are regional, and some that are local. Some you may need to do a datum transformation for. Be sure to put each one into a new data frame. What interesting things did you learn?



**Complete all of the above before class on Wednesday.**
Useful web sites about projections on coordinate systems
Do some sleuthing on the Internet and find at least five useful web sites that relate to projections and coordinate systems that either provide information or useful explanations and visualizations about projections and coordinate systems. Add them to your portfolio list, and write a short annotation for each.

**Email me just your URL list (no annotations) before 5 pm on Tuesday, Sep. 11.
The final product for this exercise – to be turned in on Friday
1. You must create a beeyooteeful ArcMap layout that illustrates a major point* that you learned in this exercise, plus why is important. You must choose from parts A-F of the exercise (i.e., you can’t choose the “fun with projections” part). The grading rubric appears on page 14.
2. Your map layout must have:
a. A title, your name, a scale, a north arrow, and a legend, if needed.
b. A graticule. Look this up in Getting to Know ArcGIS, and find out what it is and how to add it to a map. Make good choices so that your graticule balances design with adequate information.
c. Text (in callout boxes, if you like) that provides commentary on the important point, why it is important, and how it is illustrated by your map layout.
d. Consider using multiple dataframes on your layout.
3. Export your map layout as a jpeg or pdf file. Save it to your folder on the Academic Server. Be sure that your name is both on the jpeg/pdf AND in the file name. This is the last time I will remind you of this, but I will continue to deduct points if you forget in the future!!!
4. And last, copy your file of data and mxd files for Ex 2 to your folder on the Academic Server.

*What do I mean by a “major point”? A main point is not simply a topic. If you can complete the following sentence, you have a main point:

“One of the important things that I learned in this exercise is that ……and it is important because…….”

Completing the sentence above with a topic such as coordinate systems wouldn’t make sense (e.g., “one of the important things that I learned in this exercise is that coordinate systems.” Huh? Doesn’t make sense.) You need to decide what main point you want to make about a particular topic.

Ex 2: Grading rubric for Coordinate Systems and Projections Final Product

	5
	All of 4.

	4
	Everything in 3 but the text is unusually complete and clear and well tied to what is shown in the map or layout is well-designed and easy to follow or choices for nuts and bolts items enhance functionality without detracting from the design.

	3
	Purpose: makes a significant & accurate point
Text: accurate but bare bones
Nuts and bolts: title, your name, scale, N arrow, legend, graticule all present 
Layout: functional 
Design: choices for nuts and bolts items detract from the overall design

	2
	Point is inaccurate or poorly chosen or doesn’t address the assignment or text has inaccuracies or some of the nuts and bolts are missing

	1
	More than 1 item in #2
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