Exercise 1c: Coordinate systems & projections

Data sets downloaded in previous homework from NYSGIS Clearinghouse,  NYS Museum, and from CUGIR: 

· Westernville, NY orthoquad, DEC topo tiles, and DEM

· Clinton, NY orthoquad
· NY State Faults
Data sets to download from MSS: 

· continents.shp

· HC_Images folder containing two orthoimages of Hamilton College
Due: Friday, January 29 at the start of class.

Goal: 1) to explore geographic and projected coordinate systems; 2) to learn how to handle coordinate systems in ArcMap, including defining a coordinate system/projection for a data set with an unknown spatial reference and changing the coordinate system/projection both by permanent datum transformation and/or reprojection and by making the change “on the fly” without altering original data.
Turn in: this sheet with the answers to the questions plus one well-crafted ArcMap as an exported jpeg file that illustrates a major point that you learned from this exercise (details at the end of the exercise.
Part I. Geographic vs. projected coordinate systems
We’ll start by making sure that everyone is clear on what coordinates are and what a coordinate system is, and we’ll work through the differences between geographic coordinate systems (GCS) and projected coordinate systems (PCS). We’ll address any questions that you have about the reading on projections. 

Part II. Working with coordinate systems in ArcMap
As we work through some examples in ArcMap, realize that the terminology can be confusing and that the terms “project” and “projection” are commonly used very loosely and generally to refer broadly to all coordinate systems and to operations in both geographic and projected coordinate systems. 

· ArcMap uses the file suffix “.prj” for all spatial reference files, regardless of whether the file is for a geographic or a projected coordinate system. 

· ArcMap operations for defining a spatial reference or changing an existing reference are called Define Projection, Project Feature, and Project Raster, regardless of whether you’re dealing with a geographic or a projected coordinate system. And even if you want to choose WGS84 in the folder of Geographic Coordinate Systems, the choice is WGS84.prj, even though the choice does not actually project the data.

· And many people just use the terms casually – “what’s the projection for that data set?” might be a question that someone asks, regardless of whether they’re talking about GCS or PCS. 

So, part of what we’ll do in this exercise is help you keep track of the distinctions and make the right choices when you’re working with data. 

A. Exploring coordinate systems 

1. Go to the course folder on the MSS, and download the continents shapefile from the Data folder, and save it to your hard drive. In ArcCatalog,

a. Select the Metadata tab for continents.shp, choose Spatial, and click on Details. 

1. Does the continents shapefile have a PCS, or only a GCS? How do you know?

2. What is the ellipsoid? the datum?

3. Are the coordinates in meters or degrees?

b. Check the spatial metadata for the orthoquad that you downloaded from the NYSGIS clearing house.

1. Does the orthoquad file have a PCS or only a GCS?

2. What is the ellipsoid? the datum? the projection?

3. Are the coordinates in meters or degrees?

c. Check the spatial metadata for the faults file that you downloaded from the NYS museum site. What did you find? 

2. Launch ArcMap, and add your faults shapefile. Click OK when the warning box comes up. Now add your continents shapefile. Save your .mxd file.

3. Zoom to the continents layer (rt-click > Zoom to Layer). If ArcMap did the job that you hoped it would, you should be able to zoom in to New York State and see the faults in the right place. Rearrange the layers, if you need to, in order to put the faults on top of the continents layer. Are the faults where they should be? Zoom-to-layer for the faults layer. Where is it?

4. Add a new data frame to your ArcMap (Insert > DataFrame). Activate the dataframe by rt-clicking on the new data frame in the TOC and selecting Activate. This time, add the continents file first, and then the faults file. Rearrange the layers so that faults are on the top, if you need to. Are things any better?

5. Now add the Westernville orthoquad to each of the dataframes (be sure to first activate the dataframe before adding the data). Again, ignore the warning boxes. OK build pyramids. Rearrange so that it is the top layer in each dataframe. Where is the quad? Wow! What happened?

6. Get the properties for the first dataframe, and click the Coordinate System tab. What is the coordinate system of the first dataframe? 

7. Do the same for your second dataframe. What is the coordinate system of the second dataframe? Why are they different?

So, why the very different behavior for the orthoquad?? ArcMap did the best it could with the limited amount of information it had about the faults shapefile. It had numbers associated with the faults file, although it didn’t know what they meant. So, when you added the continents shapefile to the first dataframe, ArcMap assumed that the units were the same. If the faults file was a projected file with X and Y in meters, numbers would have been in the hundreds of thousands to millions. On the other hand, the degree values for X and Y for the continents file would have been much smaller numbers. They would have plotted in vastly different places in X-Y space! Why did the orthoquad show up with the faults file in dataframe 1 and with the continents shapefile in dataframe 2?

Important take-home messages:

· Don’t ignore warning boxes. I asked you to ignore them above to make a point, but you shouldn’t ignore them in the future!!!
· The dataframe will adopt the coordinate system of the first layer that is added. No amount of rearranging will change that. And if you delete the original layer hoping to solve the problem, it won’t work. The data frame still retains the coordinate system (or lack thereof) from the original layer added. The coordinate system may be either a GCS or a PCS.
· A dataframe cannot have more than one coordinate system. On the other hand, an ArcMap can have more than one dataframe, and each data frame can have a different coordinate system.
· If the coordinate systems of two data sets do not match, ArcMap will try to project a data set “on the fly” to the coordinate system of the dataframe (i.e., the coordinate system of first layer added). If the coordinate system of the dataframe or a layer to be added is undefined, ArcMap can’t do this correctly, and data sets added to such a data frame typically appear to have vanished.
B. Defining a coordinate system for a data set that doesn’t have a spatial reference (also called defining a projection).
1. Start by mosaicking together two of the DEC tiles that you downloaded from the CUGIR site for the Westernville quad. Mosaick tiles o4679c and 04579d.

a. In ArcCatalog, go to ArcToolbox > Data Management Tools > Raster > Raster DataSet > Mosaic to New Raster.  Click the “Tool Help” button if the tool help bar isn’t showing at the right.

b. In the Mosaic dialog box, input the two tiles by clicking on the folder and browsing to the first file. Repeat for the second tile.

c. Browse to an output location by click on the folder. Remember that you are selecting a folder to put the mosaic in, not naming the new mosaic.

d. In the next line, type a name for the mosaic. Short, no spaces.
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e. Scroll down to the Mosaic Colormap Mode. Although this is optional, you should make a choice here, because the colors will be screwy otherwise. Here’s a good time to learn how to use the Tool Help bar to help you. Click in the text bar below Mosaic Colormap Mode. This will bring up the help for that setting. Read through the choices, and pick the one that is most likely to produce a good mosaic if you can’t be sure that all the possible colors are present on one of the tiles. Click OK, and preview your mosaic. If it doesn’t look good, try again.
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2. Start a new ArcMap. Don’t just delete layers! Close the existing ArcMap, and launch ArcMap again. Add your Westernville CUGIR DEM. Create a hillshade. Save your .mxd file.

3. Add your new mosaic, and this time do not ignore the warning dialog box that comes up. What does the dialog box mean?
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4. This file is missing the information on its coordinate system – either the .prj file is missing, or ArcMap isn’t recognizing the .prj file. In order to properly place the file, you must tell ArcMap what coordinate system this file is in. You will do this by defining the projection (again remembering the terminology that this might actually mean defining a GCS or a PCS).

5. Well, what coordinate system might these tiles be in? It might be logical to assume that you downloaded both the DEM and the topo tiles from CUGIR and that the coordinate systems for both might be the same. You might also reason out that the full orthoquad that you downloaded from the NYSGIS clearing house ought to have the same coordinate system as the topo tiles (they certainly look the same). 

6. So, delete the offending layer from your ArcMap (you can’t make a change in ArcCatalog with the layer open in ArcMap), and go back to Arc Catalog. What coordinate system is the DEM in? How about the collared orthoquad that you downloaded from the NYSGIS Clearinghouse?
7. Well, that’s consistent. Both are in NAD27 UTM 18N. So, let’s define the projection for your mosaic to match the other two. 

a. Start by making a copy of your mosaic, and add NAD27 to the name.

b. Go to ArcToolbox > Projections and Transformations > Define Projection.

c. Click the folder icon, and browse to your mosaicNAD27 file. Click the icon to the right of the Coordinate System line to bring up the Spatial Reference Properties dialog box (next page). Click select. Which folder do you want, Geographic Coordinate Systems or Projected Coordinate Systems? Why?

d. Open Projected Coordinate Systems > UTM > NAD 1927 and select NAD 1927 UTM Zone 18N.prj. Before you click OK, check to make sure you have actually selected the right coordinate system name. The “.prj” tells you that this is actually a file that you are adding. Once you’re done, you should be able to go to Windows Explorer, go the folder with the mosaic, and find the new .prj file. If you were to send the mosaic to someone else without the .prj file, your friend would find that it is missing its spatial reference again. Click OK, and OK.
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e. Go back to ArcMap, and add your new mosaic with its defined projection. Make sure it is at the top, and increase the transparency so that you can see the hillshade below. Zoom in, browse around, and look carefully at the registration (e.g., of the edges of the lake or the valleys).  OH NO! What happened??? 
f. Use the measure tool to determine approximately how much offset there is in the NS and the EW direction. A good place to do this is on the north side of Delta Lake.

NS offset:                                                       EW offset:

g. Well, clearly we fouled this up. If we had picked the correct coordinate system, the topo tiles should have lined up with the hillshade. Just to convince yourself that this is the case, add the NYSGIS orthoquad, and check to see if it lines up with the hillshade or not. Does it?
8. We obviously made a bad assumption about the actual coordinate system for the CUGIR DEC tiles. So, what do we do? We need to find out what the coordinate system really is. Fortunately, the CUGIR site (and most reliable sites) actually have the metadata on their websites. So, go back to the CUGIR site, find the data set download page for Westernville, and, lo and behold, there’s the metadata! What did you find out about the coordinate system?

9. Go back to ArcCatalog, and make another copy of your mosaic, adding NAD83 to the name this time. Define the projection again, this time using NAD83 UTM 18N, instead of NAD27. Add your new file to your ArcMap. OH NO! Another dialog box!! This time, ArcMap is telling you that the Geographic Coordinate Systems don’t match (screen shot next page). What does this mean, and why don’t they match?
10. Again, we’re not going to ignore this dialog box. ArcMap needs to make a datum transformation in order for the new layer to line up with the DEM and the orthoquad, which both use the older NAD27 datum.
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11. Although ArcMap will happily do a datum transformation using a default setting, it is best practice to choose a transformation for ArcMap to use so that you get the best results.

a. Click on Transformations. In the next dialog box, choose Convert from NAD83 into NAD27.  In the Using pulldown, select the NADCON transformation (that’s the transformation used for NAD83-NAD27 or vice versa for the CONtinental US).

b. Click OK, and close. ArcMap does the transformation for you. Does your mosaic line up this time? Hot diggity! That’s pretty swell.

Important take-home messages for files that are missing a spatial reference:

· Don’t ignore warning boxes (do I sound like a broken record??). 

· If a file is missing a spatial reference, you must define the projection (remember, of course, that “projection” is used somewhat loosely here and could refer to defining either a GCS or a PCS).

· You cannot simply choose the coordinate system that you want the data to have. You MUST define the actual coordinate system that belongs to the data. If you do not know what that is, you must find out (e.g., from the clearing house where you downloaded the data). If you can’t find out, there are a few strategies that are better than the lame one we used in the example to try to figure out the likely coordinate system. We’ll get to those later.

Important take-home messages for datum transformations:

· For best results, make a deliberate (and correct!) choice for the datum transformation. There’s commonly more than one transformation to choose from for a given coordinate system, and the choice is commonly not as obvious as NADCON. I have printed out a spreadsheet that will help you choose the correct transformation for whatever part of the world you’re dealing with.
C. Changing the coordinate system of a set of data with a defined coordinate system to a new coordinate system (also known as projecting a raster or projecting a feature).
1. Download the HC_images folder from the MSS to your hard drive. Preview the two orthophotos in ArcMap. What is the coordinate system for the image starting with “c”? What about the image starting with “u”?
2. We’re going to make an ArcMap with these images plus the Clinton DOQ from the NYSGIS clearing house (you should have that in your Refresher folder). We’ll convert the DOQ from NAD27 to match the more recent (and more accurate) datum of NAD83 for the orthophotos, rather than vice versa.

3. We don’t need to make a copy of the Clinton DOQ first, because the projection process creates a new file (unlike the Define Projection process, which changes the original file).

4. In ArcCatalog, we will make a new Clinton DOQ with a coordinate system that matches the orthophoto with the “u” number (which is in NAD83 UTM 18N). Because the DOQ already has a defined projection, we do NOT use the Define Projection tool that we used in B above. Instead, we use the Project Raster tool.
e. In ArcCatalog, go to ArcToolbox > Projections and Transformations > Raster > Project Raster. Input your Clinton DOQ, and change the name of the output raster to something shorter and involving NAD83 so that it’s easy to see which file is changed. Do this by using the folder, not just typing into the text bar.
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f. Click on the coordinate system icon, and choose Projected Coordinate Systems > UTM > NAD83 > UTM18N. Check that you’ve chosen the right one before OKing the dialog box.

g. Choose the correct Geographic Transformation (you’re changing from one datum to another).

h. Scroll down to Resampling technique. NEAREST is fine for resampling a data set such as an orthoquad. If, on the other hand, you were resampling continuous data (such as elevation data on a DEM or pixels in an orthophoto), you should choose BILINEAR.

i. Click OK.

2. Start a new ArcMap, and add the NAD83 Clinton DOQ. Add the image with the “u” letter. You shouldn’t get any warning boxes if you’ve done everything correctly. Zoom in, and check to see if everything lines up well. Save your .mxd file. We’ll use it again for the next part of this exercise.

Important take-home messages for converting coordinate systems:

· Don’t ignore warning boxes (do I sound like a broken record??).

· Do not use Define Projection to convert a data set from one coordinate system to another. Define Projection is only for setting the coordinate system for files with unknown spatial reference (see Part B above).

· Use Project Raster (for raster files) and Project Feature (for shape files) to convert a data set from one coordinate system to another. Remember that these tools are also used to convert geographic coordinate systems to other geographic coordinate systems, even though “projection” is not involved.

· It is best practice to have all your data in the same coordinate system before starting a project, rather than having ArcMap project on the fly. 

· It is also best practice to convert files in older coordinate systems to more recent ones that are the most accurate for the area in question.

· Reprojecting data more than once degrades the data. Indicate somewhere in the file name what the new coordinate system is so that you know which are your original files. If you need to convert again, start with a new copy of the original data, not with one of the reprojected files.
D. Changing the coordinate system of a set of data to a new coordinate system temporarily “on the fly”
1. Add the original Clinton DOQ (in NAD27) to your ArcMap from the previous section. You should get a warning dialog box. Make the appropriate choices for the datum transformation (as you did in part B). Click close, and ArcMap adds the re-projected DOQ to the map.

2. This is what’s know as projection “on the fly”. This is a temporary re-projection that does not change your original data file. 

3. Now, add the other HC orthophoto (the one with the “c” number. Does its coordinate system match the one with the “u” number?
4. But you didn’t get a warning box! Because both are in NAD83, no datum transformation was involved, just a re-projection from UTM to State Plane. ArcMap just did this on the fly without warning you. Check to see if the two photos line up well – they should.
5. And one last thing. Add a new dataframe, and add your original Clinton DOQ (the one in NAD27) to that dataframe. Remember that a dataframe has the coordinate system for the first layer added to that dataframe, so one data frame is in NAD83 and the other is in NAD27.
a. Activate the NAD27 dataframe. Zoom in until you can see the symbol for the Science Building (remember that this is an old map, so it won’t have the whole new Sci Center). 

b. What are the UTM coordinates for our classroom in the NAD27 datum?

c. Now activate the NAD83 dataframe. Zoom in on the Science Building symbol. What are the UTM coordinates for our classroom in the NAD83 datum?

d. How much different (in meters) is the northing? How about the easting?

e. Then, go to Google Earth. What are the Google Earth UTM coordinates for the same spot? What datum does Google Earth use?

f. Remind me that you know why the coordinates are different in NAD27, NAD83, and WGS84.

E. And a little fun with projections
1. Start a new ArcMap, and add the continents shapefile.

2. Add several new dataframes. Remember that to change a dataframe name or to add something to a dataframe, you need to activate it (rt click > Activate).

3. We’re going to take advantage of projecting on the fly to do a little experimenting with projections. By projecting on the fly, you won’t clog up your folder with new shapefiles.

4. Activate the first new dataframe. If we set the projection of the dataframe, and then add the continents shapefile, ArcMap will project the continents on the fly and display it in the new dataframe.

a. Right click on the new dataframe name, and select Properties. Choose the Coordinate System tab > Predefined > Projected Coordinate Systems.

b. Use the list of map projections in the handout, or just try out one that sounds interesting in the list on the screen. Rename the dataframe to reflect the projection name.
c. Add the Continents shapefile to your new dataframe. ArcMap projects it on the fly! But remember, your original data are not modified, and there’s no new shapefile in your folder. If you want to make the projection permanent, you need to use ArcToolbox, and Project Feature (not raster, because this is a shapefile) to create a new, projected shapefile.

d. Try out at least 5 or 6 other projections, trying some that are global, some that are regional, and some that are local. Some you may need to do a datum transformation for. Be sure to put each one into a new dataframe. What interesting things did you learn?

F. The final product for this exercise
1. You must create a beeyooteeful ArcMap layout that illustrates a major point* that you learned in this exercise, plus why is important. You must choose from parts A-D of the exercise (i.e., you can’t choose the “fun with projections” part).
2. Your map layout must have:

a. A title, your name, a scale, a north arrow, and a legend, if needed.

b. A graticule. Look this up in Getting to Know ArcGIS, and find out what it is and how to add it to a map.

c. Text (in callout boxes, if you like) that provides commentary on the important point, why it is important, and how it is illustrated by you map layout.

d. Consider using multiple dataframes on your layout.

3. Export your map layout as a jpeg file, and save it to your folder on the MSS as well.
*What do I mean by a “major point”? A main point is not simply a topic. If you can complete the following sentence, you have a main point:

“One of the important things that I learned in this exercise is that ……”

Completing the sentence above with a topic such as coordinate systems wouldn’t make sense (e.g., “one of the important things that I learned in this exercise is that coordinate systems.” Huh? Doesn’t make sense.) You need to decide what main point you want to make about a particular topic.

2010 – Barbara Tewksbury, Hamilton College, btewksbu@hamilton.edu
page 1

