Using GIS to estimate the volume of snow and water in a drainage basin

By Dave Tewksbury and Todd Rayne

Today you will start work on an outdoor/indoor exercise to get you thinking about the relationship between linear, area, and volume measurements.  Of course, these are not the same – they have different dimensions, they have different units, they are used for different purposes, and they tell you different things.  For example, meteorologists usually measure precipitation in a linear fashion (e.g. 6 inches of snow fell last night).  As hydrologists, we often want to know what volume of water fell within a drainage basin because the units are more comparable to streamflow measurements.

In this exercise, you and a partner will make linear measurements (units of length, L) in an area (units of length squared, L2) in order to determine volume (units of length cubed, L3).  We will also examine the relationship between snow depth and water content. You’ll plot your data in ArcMap and use the software to create contours of snow depth, which you can convert to volume by a method shown below.

At the end, you’ll estimate the volume of runoff derived from melting snow by combining the snow volume with a water equivalent estimate of the snowpack and a runoff coefficient.

Equipment and software:
Meter sticks for measuring snow depth

GPS units to locate XY position of measured points

Notebook to record location and snow depth

Excel to construct spreadsheet of collected data

ArcGIS with Spatial Analyst extension

DEM (digital elevation model) of drainage basin

Orthophoto or DRG (digital raster graphic) of basin for defining limits of study area.

Products:
1. A GIS map of the project area showing the volume of snow

2. Calculations of the volume of snow and water in the area

3. A short essay in which you discuss the limitations and potential errors associated with this method of determining the volume of water. We’ll discuss the structure of the essay during the lab period.
Part 1. Collecting Field Data
· I’ll divide you into teams of two people.  Each team will need a measuring stick, a GPS unit, and a notebook for data recording.

· Our field area is the northwest campus, broadly defined as the area west of a line between the Science Center and Dunham and north of Griffin Road.  The area includes the soccer, football, baseball, and softball fields and the golf course out to the farm field. You’ll have about 90 minutes to make measurements of the snow in this area.  Try to cover as much of the field area as you can in the time you have and try to sample in a grid-like pattern - not just along the perimeter of the area.

· At each point that you measure the snow depth, record it (the depth) and your coordinates (from the GPS unit) in your notebook. 

Part 2. Volume estimation and analysis (the GIS part)

The first step is to enter your snow depth measurements into Excel.  
· A default new Excel workbook contains 3 pages with names Sheet 1, Sheet 2 and Sheet 3 on the tabs. 

· Renaming the Sheet 1 tab with something useful like snow depth data will make it easier assure loading the correct data into ArcGIS later on. The other two sheets can be deleted.

· The sheet will need 3 columns that you should name Easting, Northing and SnowDepth.
· Enter the data collected in the field into the appropriate fields. Be sure not to mix Easting and Northing measurements (in our area Easting will be around 466877m E, and Northing 4766902 m N.

Northing and Easting are in meters so snow depth must also be in meters for the volume calculation to be correct.
Save the Excel file to your GIS folder.

Creating the base map in ArcGIS:
1. Open a new map document

2. Be sure to set save relative pathways so you can work on this from other computers

3. Add the Clinton DEM  and the Hamilton College orthophoto mosaic 

4. Orthophoto layer should be on top of the DEM

5. These data sets have all been processed to be in the same coordinate system, NAD 83 UTM 18N

6. Name and save your map to your folder on the academic software server

Add the field measurement data:

1. In the main menu bar click Tools > Add XY data

2. Click on the browse icon next to the Choose a table field, navigate to Excel data file and drill down to the individual sheet

3. If you did not rename the tab in the workbook this will be Sheet1$

4. Next set the X and Y fields to match the corresponding fields on the spreadsheet

5. Finally, specify the coordinate system for this data. This concept should be familiar from the introductory exercises. If not, check with your partner or me. 
6. Click the Edit button then the Select button double click Projected Coordinate Systems folder then the UTM folder and finally the NAD 1983 folder and select the NAD 1983 UTM Zone 18N.prj file and click Add.

You can also Import the projection from the HC orthophotos by 

Edit > Import > browse to the HC orthophoto raster file
When all fields in the Add XY data dialog box are set correctly, click OK and you should see a set of points on the map.

Colors are assigned by default by ArcGIS, change color to something you like that shows up well.


7. Convert the $Event layer to a shapefile by right-clicking on the $Events layer in the TOC and selecting Data > Export Data.  Browse and name a shapefile in the proper directory.  Name it Snow_depth.shp.

Save the map

If the map does not look correct, check that the X&Y fields were set correctly (Easting is X and Northing is Y) If you reversed the Easting and Northing values in the spreadsheet (Easting values entered in the Northing column and Northing values entered in Easting column) stations will not plot correctly. Also check that the coordinate system was set correctly.

 Acquiring elevation data from DEM at stations: 

In order to do volume calculations within ArcGIS, a surface for the top of the snow needs to be generated. This surface elevation is the elevation of the underlying ground surface plus the measured snow thickness. Spatial Analyst toolbox has an extraction tool to get data from layers underlying specific points such as those defined by the GPS data.

1. Open the Spatial Analyst toolbox (add toolboxes if necessary) select Extraction and Extract values to points.

2. Spatial Analyst Toolbox > Extraction > Extract values to Points
3. Set the appropriate files in the dialog box

4. The input point feature is the GPS station file (the shapefile you just created from the Excel data.)

5. The input raster is the Clinton LIDAR file

6. Browse to name and save the output file

ArcMap automatically adds resulting file to the map and this layer should exactly overly the existing stations layer.

Open the Attribute Table of the extracted values layer, a column called RASTERVALU is present.

These are the elevations of the ground surface underlying the stations as derived from the LIDAR. Elevation is in meters.

Using the RASTERVALU and the measured snow depth values it is easy to calculate the elevation of the snow surface. 

Creating a snow surface elevation field in the attribute table: 

Add an additional column to the attribute table. Remember you cannot be editing when adding a column. This column will contain the results of a calculation adding the ground surface elevation (RASTERVALU) and the measured snow depth. The RASTERVALU field is carried out to 6 decimal points, precision without accuracy!

The LIDAR DEMs have a vertical accuracy of less than one meter per the metadata. 

To make the resulting values more reasonable, set the new field values as: 

· Name: Snow_elev

· Type: Double

· Precision (total number of digits displayed): 6
· Scale (total number of digits to right of decimal point): 3
To populate this field use the field calculator:
1. Right click in the column title and scroll to field calculator.
2. OK warning box that you are doing a calculation outside of an edit session. 

3. Build equation for snow elevation by double clicking RASTERVALUE, clicking the Plus sign and double clicking snow_depth.
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Once complete, click OK and column will fill with values defining the elevation of the snow surface.

These data will be used to construct the snow elevation surface used for the volume calculation. But one additional step is needed to make the calculation as accurate as possible.

Creating a Polyline boundary to limit the surface extent:
1. Create a polyline shape file in ArcCatalog with the same coordinate system as the HC_orthophotos

2. Add this layer to ArcMap document

3. Start Editing (be sure setting is to create new feature and the correct layer is selected)

4. Using the pencil tool draw a boundary surrounding the sample area.  (If you have a drainage basin outline from another source, you should use this as your boundary.)

5. This is a polyline shape file and will not close on itself automatically. Be sure that the final click is directly on top of the starting point to form an enclosed area.

If you make a mistake, click stop editing, do not save edits and start again. When correct, click stop editing and save edits.

The polyline boundary will be used to limit the surface created in the next step.

Create a surface from the snow elevation point file: 

1. Using Spatial Analyst extension in the main menu bar
Spatial Analyst > Interpolate to Raster > Inverse Distance Weighted (IDW)
2. Set the Input Points to the layer with the snow_elevation data
3. Set the Z field to Snow_elev (scroll down in the pull down menu to find the correct Z value field. Do not use the snow_depth values for this calculation.

4. Leave all other values at defaults

5. Check the Use barrier polylines box and set the polyline file in the pull down menu, 

6. Browse and name the output raster as snow_elv_sur
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A color coded surface file is generated and the layer is automatically added to the map. The default symbology color and number of classes can be modified in the layer’s properties.

This surface in conjunction with the original DEM  is used to calculate the area and volume of snow within the sample area.

Calculating the Area and Volume of snow:
1. Using Spatial Analyst toolbar in the main menu, pull down to Surface Analysis > Cut/Fill
2. The Before Surface is the Clinton DEM
3. The After Surface is the snow_elevation surface
4. Leave Z factor and output cell size at defaults

5. Browse  to name and save output file

6. Click OK
Output is automatically added to the map as a three colored raster. Red indicates areas that have a net gain, blue a net loss and gray no change. Map should be predominately red because the snow added elevation to the original land surface.  Below is an idealized map; your map may have blue, red, and gray areas.

Open the attribute table of the Cut/Fill layer to display the volume and area calculations. The net gain volume is expressed as a negative number. This is due to how the volume calculation is done. 

Volume = (cell area) *  Z   where  Z  = Z before –  Z after 

(the larger number subtracted from smaller number)
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Area and volumes are in units used in the map projection. In this case the projection and datum is NAD 83 UTM which uses meters as the unit of measure.  Therefore, area is in square meters and volume in cubic meters. 

Now let’s calculate the volume of the red cells.  In the idealized example shown here, it’s easy.  Simply read the one negative value from the attribute table – that’s the volume of snow in m3.  But most of your maps will have some blue areas that ArcMap interprets as areas where you have no snow.  

Thought question: why does this occur when you know that the entire area was covered by snow?

Here’s how to sum only the red areas:

Open the Attribute Table of the Cutfills between layer.  Click on Options > Select by Attribute and a dialog box will open.  Double click on “VOLUME” in the upper box, then on the <= sign in the gray area, then type a 0.  Click Apply and the negative areas in the attribute table should become highlighted in blue.  Then click on Options > Export and browse to your Snow folder.  Create a name like Snow_volume and click OK.

Launch Excel and open the .dbf file you just created.  Make sure you select All Files in the Files of Type option in the Open dialog box.  Sum the values using the =SUM(..) function.  The total is the volume of snow in m3 in your field area.

Converting to volume of water:  

Using a device called a Federal Snow Sampler, we’ll measure the water equivalent of the snowpack in multiple locations. The average water equivalent is used to calculate the density of the snow:

Depth of snow x density of snow = depth of water x density of water

Solve for the density of snow and use it to solve for mass of snow (and water) using this equation:

Volume of snow x density of snow = mass of snow, which is also the mass of water

Finally, solve for the volume of water using this equation:
Mass of water / density of water = volume of water

Remember that the density of water = 1000 kg/m3
Discussion

During the week after this lab, we’ll take some time during class to discuss the following:

· Troubleshooting GIS problems 

· Conversion of snow volume to water volume

· Discussion of why all the cells in the study area are not red

· Discussion of snow accumulation and hydrology 
Note to instructor:

One way to eliminate the blue cells that indicate negative snow volume is to have the students multiply their snow depths in Excel by some factor (10, 20, etc.) and use those snow depths in the exercise. At the end of the exercise, divide the volume of snow by the same factor to correct it.  This is especially valuable when the snowpack is thin and the effect of topographic variability and snow surface elevation interpolation will give you lots of negative snow volume. 

