Geog 359 Project 1 (apartment information system) Part 1
The semester is about to start and many students are looking for apartment to rent. One of the drawbacks of traditional house/apartment lists is that it does not give you very good spatial information (i.e., where they are) unless you are very familiar with the area. In order to help yourself and other students to find apartment more easily, you want to use the GIS skills you learned so far to build an Apartment Information System.   

The purpose of this project is to be familiar with the entire process of creating a GIS project from data capture through analysis and result map generation using GeoMedia Pro.  Most of the things you will do you have already learned in previous labs. This is a chance for you to apply the skills you learned before to build a project from scratch.
Part 1 involves creating a GeoWorkspace, creating a new Warehouse, defining a coordinate system, defining a feature class, inserting an image, and digitizing a feature. The whole project is due in two weeks (i.e., for Tuesday lab, it will be due 10/17; for Friday lab, it will be due 10/20). 

Copy files to you personal project folder

1. Open Windows Explorer to copy the lab7 folder under a_data_359 to your personal folder.
Create and save GeoWorkspace

2. Start GeoMedia Professional, if it is not running.

3. Select File > New GeoWorkspace from the menu bar. 

4. On the New dialog box, accept the default template, Normal.Gwt, by making sure normal appears in the File name field and Document is selected, and by clicking New. 

5. Select File > Save GeoWorkspace As. 

6. In the Save in field, navigate to your personal project folder s:\<your lastname>\lab7\

7. In the File name field, delete the existing text (untitled) and type the name lab7apt. 

8. Click Save. The geoworkspace is saved as s:\<your lastname>\lab7\lab7apt.gws.

NOTE: Any time you exit GeoMedia Professional, save the GeoWorkspace first, unless you don't want to keep any changes since last save.

Create a new Warehouse

1. Warehouse > New Warehouse…. The "New" dialog window opens.

2. Make sure the default "normal" is in the File name field, click on New button. The "New Warehouse" dialog window opens.

3. In the Save in field, click on the dropdown list and select the following directory s:\<yourlastname>\lab7\

4. In the File name field, delete the existing text and type the name lab7apt.

5. Click Save. The warehouse is saved s:\<yourlastname>\lab7\lab7apt.mdb.

Define coordinate system

1. View > GeoWorkspace Coordinate System…  This and the next step set the coordinate system to be the same as the features that will be defined shortly.

2. Click on Load, navigate to your project folder and select the orthoile.csf file. This is coordinate system file (csf) for Illinois East State Plane coordinate system that was created earlier. 
3. Click on Open; Click on OK 

Define Feature Class

1. Warehouse > Feature Class Definition…, "Feature Class Definition" dialog window opens.

2. Click on New… button, "New – Feature Class 1" dialog window opens.

3. Click on New button under Coordinate System
4. Click on Load, navigate to your project folder and select the orthoile.csf file.

5. Click on Open. Click on OK. You should be back to “New – FeatureClass1" dialog window.

6. Click on Set as default; in this way all future features you define will take this coordinate system.

7. In the Name field, change FeatureClass1 to ApartmentOutline
8. In the Description field, type some descriptive words, e.g., "Boundary of apartment complex"

9. In the Geometry Type field, drop select Area.

10. Click on Attribute Tab, click on the white space under Key field, click on Set Primary Key button; a key symbol [image: image1.png]


 appears. This will be the primary key field for this attribute table.
11. Click on Attribute1 under Name field, change it to Apartment_ID; drop select Long Integer under Type field; Under Format, select General Number. 

12. Follow steps 2, 7-11 to define features Road and OrthoPhoto and their associated attributes shown in tables 2 and 4.  The tables below give you a summary of what each of the feature class definitions should look like.

Note: To save you some manual attribute input, a more detailed apartment attribute table will be joined later using Apartment_ID as the key.

Table 2 Feature class

	Feature Class Name
	Description
	Geometry Type
	Attributes

	ApartmentOutline
	Outline of apartment complex
	Area
	see Table 3

	Road
	Road 
	Line
	see Table 4

	OrthoPhoto
	Aerial Ortho photo
	Image 
	see Table 5


Table 3 Attribute table associated with ApartmentOutline

	Name
	Key
	Data Type
	Description
	Format

	Apartment_ID   
	Yes
	Long Integer
	Apartment ID #
	General Number


Table 4 Attribute table associated  with Road 

	Name
	Key
	Data Type
	Description
	Format
	Length

	Road_ID
	yes
	AutoNumber
	Road ID
	-
	-

	Road_name
	no
	Text
	Name of the road
	-
	30

	number_of_lane
	no
	Integer
	Number of Lanes
	General Number
	-

	date_paved
	no
	Date
	Date last paved
	Date
	-


Table 5 Attribute table associated with OrthoPhoto

	Name
	Key
	Data Type
	Description

	Ortho_ID   
	Yes
	AutoNumber
	Ortho Photo ID


Insert orthophoto image

1. Insert > Georeferenced Images…;

2. Under Georeference mode, drop-select Intergraph header matrix
3. Under Coordinate system file, browse to select coordinate system file orthoile.csf from your folder s:\<your lastname>\lab7\.

4. Under select images Folder, browse to select your personal project folder s:\<your lastname>\lab7
5. Select niulow2.tif; click on >, make sure warehouse is lab7apt and feature class is OrthoPhoto
6. click on OK
7. Legend > Add Legend Entry, and select OrthoPhoto. The image will be displayed.

.

Verify coordinate system and enhance image contrast

1. Make sure Current coordinate format is set to Lon, Lat(d:m:s), this is the field above the Map Window 1.

2. Move the cursor anywhere in the image, the degrees of lon, lat coordinate should read –88, 41.

3. If not, you need to go back and check your coordinate system setup.

4. Right click on OrthoPhoto in the Legend. Style Property window opens.

5. Under Grayscale/Color image tab, adjust the contrast and the brightness until you are satisfied with the way the image displayed.

6. Click OK.

Digitize apartment and road features

1. Insert > Feature, OR click on the Insert Feature icon (the first from top on the left beside MapWindow1)

2. Click Select Feature Class field and select ApartmentOutline feature

3. Reference the hard copy map (attached), digitize the apartment outline for apartment complex number 1; when you finish, right mouse click, select end feature. The ApartmentOutline property window opens;

4. Enter number 1 in the value field.

5. Repeat steps 3 and 4 to digitize the rest of the apartment complexes.

6. Repeat steps 1 to 5 to digitize the road feature, you should enter the road name accurately, the road id will be automatically filled for you since we defined it as autonumber, for the rest of the attribute you can fill some made-up value.

Insert labels
1. Insert > Label…

2. Under Label features in field, drop select ApartmentOutline under lab7apt 

3. click on Apartment_ID under attributes field

4. under output label as, select Query
5. Query name: AptLabel 

6. change style, or you can do this step later

7. click on OK
Create a new feature to hold interactive label

Before you insert interactive label, you need to create a new feature to hold interactive label. Select Warehouse > Feature Class Definition… to create a new feature called RoadLabel, with geometry type as text, with only one attribute column label_id, and data type AutoNumber
Insert Interactive labels

1. Legend > Add Legend Entries…, select RoadLabel. (without this step, the label won’t show on the map)

2. Insert > interactive label…

3. Under Label features in field, drop select Road under lab7apt 

4. Click on Road_name under attributes field

5. In the Output label to field, drop select RoadLabel under lab7apt 

6. Drop select Rotate dynamically in orientation field

7. click on OK

8. Note the text on bottom bar. Place the cursor on to a road feature that you want to place the label. Click to select that road. The road_name of that road will be read from the database. 

9. Note the text on bottom bar. Click at a location where you want to put the label

10. Note the text on bottom bar. Move you cursor until you get the angle you like, click to place the label.

11. Make sure that all labels appear above the roads (i.e. pull them to the top of your Legend entries).

Add north arrow and scale bar to the map view and save

1. View > North Arrow

2. View > Scale Bar

3. Edit > North Arrow Properties (or just double click on the north arrow) to modify the properties to your liking.

4. Edit > Scale Bar Properties (or just double click on the Scale) to modify the properties to your liking.

5. Legend > Name Legend, name it AptLegend

6. File > save geoworkspace
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Geog 359 Project 1 (apartment information system) Part 2
Part 2 of this project involves attaching a text file containing detailed apartment attribute information into an Access database, joining this detailed information with the spatial object you have digitized, and creating spatial queries based on location and attribute criteria. 

Attach a text file into GeoMedia

1. Warehouse > Feature Class Definition to open the Feature Class Definition dialog box.

2. On the Feature drop-down list, double click the lab7apt read/write warehouse connection.

3. Click Attach.

4. Select Text from the Type drop-down list.

5. Select Browse to locate the file attable.txt in your personal project folder  

6. Click OK.

Create a join

1. Analysis > Join…;

2. for Left side of join, click on lab7apt, drop select, ApartmentOutline
3. for Right side of join, click on lab7apt, drop select, attable_txt
4. click select Apartment_ID (on the left) and apt_id (on the right)

5. click the down arrow (V) button

6. make sure inner is selected for Type of join, click on OK
7. Close Data Window

Make the join a new feature and display it in map window

1. Warehouse > Output to Feature Classes…

2. select Join of ApartmentOutline and attable_txt under Source connections and queries 

3. for Target Connection drop select lab7apt
4. click on Advanced tab

5. for Target Feature class, type in ApartmentOutlineWithAttribute
6. make sure Display feature class in map window check box is selected
7. click on OK; click Yes, Click on OK
8. click on ApartmentOutline in legend to highlight it, hit the delete key, click on OK to delete this entry from the legend. (Don’t worry, the feature is still in the database, we are just making it disappear from the map window.)
9. double click on the ApartmentOutlineWithAttribute in legend
10. Under style pick the appropriate color, weight, and so on for the area boundary and area fill
11. click on OK (if you don't like your choices, go back and try different ones)

Build a Practice Attribute Query 

We will find the apartment complex that has a minimum rent less than $350.

1. Analysis > Attribute Query…

2. click on the drop down arrow beside Select Feature in field
3. click on lab7apt
4. select ApartmentOutlineWithAttribute
5. click on Filter
6. type in min_rent < 350 or you can use a combination of selecting the items from the list and typing

7. click on OK
8. Give it a descriptive name such as minimum rent less than 350 

9. click on OK.  Review the result in data window. Close or minimize the datawindow.
10. change the style of the result query in the map window so that it shows well.

Build a Practice Spatial Query

We will find apartment complex that are within 100 ft of Edgebrook road.

1. Analysis > Spatial Query…

2. drop select ApartmentOutlineWithAttribute for Select feature in
3. under That field, drop select are within distance of
4. under Distance, type in 100, under Units: drop select ft.

5. under Features in, drop select Road
6. click on Filter (next to the feature “road” that you just selected), double click on road_name under Attributes
7. click on = sign under Operators

8. click on Show Values button, click Yes to the question, double click on Edgebrook Road
9. give it a descriptive name such as Apt within 100 ft of Edgebrook, click on OK. Review the result in data window. Close or minimize the datawindow.
10. change the style so that it shows well in the window

The above is just a practice to get you familiar with the procedure. Now suppose you want to find an apartment to share with a roommate that should meet the following criteria:

· has two bedroom 

· rent is $650 or less
· utility uses electricity

· is within 300 ft of Hillcrest road. 

Please use the GIS you just built to arrive at an answer.

Hint: (1) In attribute query you can use logical operator AND. (2) In spatial query, you can use previously created query as input (i.e., under the Select feature in box, instead of selecting a feature, you can select a query).

Please hand in: 

(1) simple printouts of the two practice queries above

(2) a flow diagram that summarizes the big steps of building this project (focus on big picture of the whole project)  

(3)  a more detailed flow diagram showing how you solved the final problem (You should have a flow diagram before you start working on the final problem on computer)

(4) a map showing the apartments that meet the criteria

(5) a table showing all the attribute information of the apartments that meet the criteria;
(6) answer to the following questions:
If you were to do a project for the whole United States, what projection would you use? Why? How about the whole world? Why?

On the attribute information, what other additional attribute fields would be helpful/beneficial for you to find the apartment you want?

The map should show all the apartments with ID and roads with name and the orthophoto, with the apartments meeting criteria highlighted in a different pattern shown in legend. You can create a nice map following the instructions from last lab.  The steps are repeated below for your convenience.

Create a nice finished map output 

1. Window > Show layout window; the layout window opens. 

2. File > Page setup; change orientation to Landscape. Click on OK.

3. View > Fit; This makes it fit to maximum extent.

4. Click on Insert Map button 
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. Under method, drop-select Rectangle.

5. Click on OK. Notice the bottom of the window is prompting you what to do. Click a top left point and a lower right point to define a rectangle so that the map you want to show is within the rectangle.

6. Now you are back to the layout window. Move your cursor so that the rectangle is at a desired location and click. Your map will be placed.

7. Click on the map frame and click on the Insert Legend button 
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. Delete any unnecessary legend entries.  This will only delete them from the legend not from your map properties.  Again notice the bottom of the window has text telling you what to do. Move your cursor to a desired location and click to place the legend.

8. Click on the Insert North Arrow button 
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. Move your cursor to a desired location and click to place the north arrow

9. Click on the Insert Scale Bar button 
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. Move you r cursor to a desired location and click to place the legend.

10. Click on the Text Box button [image: image7.png]


.   Type a title for each of the map layouts that you print out.  You may make changes to font and size of the text. To do this, right click on the text, select properties, a window will open, click on Paragraph tab, make changes to font, font size, color, etc. as you wish, click on OK.

11. Using another text box, type in your name, date, lab section, etc.

12. You can make adjustment to the map elements and click and dragging them.

13. Once everything looks good, File > Save to save it and File > Print to print the map.
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