
FRS 135 State of the Earth: Shifts and Cycles (in Spain)

Lab 02a: Campus GPS – I I09/30/2015

Due: 09/30/15 – upload your spreadsheet to Blackboard by 6:00 pm Wednesday.

The purpose of Lab 02a is to become familiar with your Global Positioning System (GPS)
unit and with basic GPS surveying. By the end of Lab 02b, you should have learned how to
set up a survey, how accurate your GPS unit actually is, and some data analysis in Matlab.

1 Waypoints, Control Points, Control Line

During every GPS survey one must set up a network of special WAYPOINTS (WP) called
CONTROL POINTS (CP), and resurvey these control points once or twice a day for the
duration of the survey. By collecting a time series of data from these special control locations,
one can evaluate how precise and stationary a GPS measurement is, and take the observed
error into account when analyzing the actual GPS survey.

In this assignment, you will study four control points (CP1–Glacial boulder, CP2–NE Dillon
sign, CP3–Cannon and CP4–SW Firestone statue; Figure 1). Every one of you will take
control points from the exact same locations (as pointed out by Adam during the campus
walk on September 24). Each person will visit each control point at least once per day
(of course, the more times you can revisit a control point the better!) over the next week.
The more measurements you have, the more fun your data analysis will be.

While the CP survey will allow you to test the reproducibility (precision) of your GPS
unit, it will not allow you to test its accuracy, because you do not know the exact absolute
location of each control point. Therefore, you also will study one CONTROL LINE (CL).
Control lines allow you to test the accuracy of the Garmin GPS as you compare your CL
data to a straight line (you will be doing a regression).

To collect CL data, you will start on one end of the line and collect a waypoint. Then, you
will walk in a straight line (choose one edge of the road/sidewalk/grass, and always follow
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Figure 1: Princeton Campus map, showing the location of the four control points with red circles (CP1–
Glacial boulder, CP2–NE Dillon sign, CP3–Cannon and CP4–SW Firestone statue), and the one control line
with a red line (CL5–Chapel Drive).
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the same edge) toward the other end, taking a new waypoint after every ten steps. Practice
taking consistent steps, and work with a friend to figure out how long each stride is (so you
will know how long the distance should be between the waypoints). To determine your stride
length, take ten steps, and then measure that distance with a ruler and divide by ten (do
that at least three times to check for consistency). All of the waypoints you take associated
with your control line survey should be labeled CL5.

In your orange notebook, build a table of your observations that looks exactly like this:

WP CP(L) UTMz East North Elev Paces ∆XY GPSelev Acc MM DD YYYY hh mm Sats Met
22 3 18 528955 4466458 70 0 0 1.2 6 9 25 2015 15 23 9 5

You might separately also record information about how long you stood in one place with the GPS
held in position before acquiring a waypoint, how long you allowed the GPS to average its position,
how close you were to any high walls or objects that might make satellites low in the sky difficult
to see, etc. But the table above is the information that all of you must have.

• WP is the three-digit waypoint number that your GPS records for each point. In the example
above the measurement is the 22nd point recorded on the GPS unit.

• CP is the number-identifier for the control point that you are surveying. For example, if you
collect a point at the cannon, you would write the number 3. If it is the control line (CL),
the number is 5.

• UTMz is the UTM zone for your location. New Jersey is in Zone 18.

• East is the x-value (easting) in UTM coordinates, with units in meters. The cannon has an
easting of roughly 528955 m.

• North is the y-value (northing) in UTM coordinates, with units in meters. The cannon has a
northing of roughly 4466458 m.

• Elev is the z-value in UTM coordinates, with units in meters above the WGS84 spheroid
(roughly sea level).

• Paces is the number of stride lengths between this waypoint and the previous one when you
are surveying the control line (CL) — otherwise, put in a zero.

• ∆XY is the distance in meters between this waypoint and the previous one (using your
calculated average pace length) when you are surveying the control line (CL) — otherwise,
put in a zero.

• GPSelev is the height at which you hold your GPS when taking a measurement. Measure
this height once after you are comfortable holding the GPS unit, and then try to hold the
GPS at that height above the ground for all future measurements.

• Acc is Garmin’s stated positional accuracy, listed on the Satellite page as ±xx. Note that
accuracy is not automatically recorded in the Garmin data file, so you must write it down!
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• MM is the two-digit month, 01 to 12.

• DD is the two-digit day, 01 to 31.

• YYYY is the four-digit year, 2011.

• hh is the two-digit hour read on your GPS unit, in 24-hour format, Eastern Standard Time.

• mm is the two-digit minutes read on your GPS unit.

• Sats is the number of satellites used to compute your location and is crucial information not
recorded in your Garmin data file. Each time you record a control point, navigate to the
Satellites page and write down the number of satellites (solid colored bars) that you have for
this particular measurement.

• Met is a qualitative description of local weather when you record each waypoint. For purposes
of analysis that involve grouping and binning, it is important to minimize and standardize
the number of terms used. Therefore, for Lab02, describe the weather using the following
numerical codes:

– 1 – clear skies

– 2 – partly (≤50%) cloudy

– 3 – cloudy (>50%)

– 4 – fog

– 5 – light rain

– 6 – heavy rain

– 7 – lightning and thunder without rain

– 8 – lightning and thunder with rain

2 How to turn in your assignment

• Copy your table into Microsoft Excel, Apple Numbers, Gnumeric, Open Office Calc, or
whichever spreadsheet program you like to use. We have attached template.csv for you to use
if you like.

• In your spreadsheet program, save your simple spreadsheet with the control point and control
line data as a ‘comma separated values’ (∗.csv) file. You need seventeen columns with only
numeric data (no letters or symbols, so delete the header row): no more, no less.

• Upload your correctly-named (e.g., ‘netidl02a B.csv’, where ‘netid is your Princeton Net ID,
‘l02a’ is for you know what, and ‘B’ your GPS-ID labeled on the back of your GPS unit)
spreadsheet to Blackboard by 6:00 p.m. on Wednesday September 30. Use the underscore!!
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3 Alternative approach to filling in your GPS spreadsheet (make
sure you read before you collect any data)

Eventually you will collect much larger GPS data sets and will not want to record all the GPS
measurement detail in your notebook, and then input the data into Excel by hand later. In fact,
you may not want to enter your CP and CL data by hand now, so here is another option. But
before we get to the instructions, here are two words of wisdom: First, you still need to take
field notes. A lot of information is not recorded in data files by your Garmin, such as CP(L),
Paces, ∆XY, GPSelev, Acc, Sats, and Met. Therefore, you will still need to fill out those cells in
your field notebook table, next to the waypoint number assigned by your GPS to each point. A
simplified spreadsheet for your notebook could look like this one:

WP CP(L) Paces ∆XY GPSelev Acc Sats Met

022 3 0 0 1.2 6 9 5

Then, you will combine your field notebook with the GPS position and time data you download from the
Garmin unit (see instructions below). Second, the instructions below will serve as the recipe for GPS work
that you will use throughout the Spain/France trip – so it will not hurt to get familiar with the protocol
now. The best protocol for downloading and filtering your GPS data is as follows:

(A) Install GPSBabel, which is a free software for MAC, PC or Linux. If you own a MAC, the ‘GPSBabelFE’
should go in your ‘Applications’ folder.

(B) Open up GPSBabelFE and you should see the GPSBabel graphical user interface (GUI).

(C) Use your usb-connector cable (any mini-usb-to-usb cable typically used with cameras and other devices
works) to connect your Garmin GPS to your computer (please arrange to share the cables with your
peers).

(D) In the GPSBabel GUI:

(i) Select the Input = Device radio button (Fig. 2A).

(ii) Select Format = Garmin serial/USB protocol from the Input pull down menu bar (Fig. 2A).

(iii) Just leave the Options button and window alone.

(iv) Select the Output = File radio button (Fig. 2A).

(v) Select Format = Universal csv with field structure in first line from the Output pull down menu bar
(Fig. 2A).

(vi) Under Translation Options, deselect Routes and Tracks so that only the Waypoints box has a check
mark next to it (Fig. 2A).

(vii) Under Translation Options, do not do anything with the Filters or More Options buttons (Fig. 2A).

(viii) Back to Output, click the File Name button (Fig. 2A). Navigate to your ‘/Users/netid/frs135/Labs/lab02a’
directory and name the file ‘netidl02a Braw.csv’, where the ‘B’ is your Garmin GPS letter, and
the ‘raw’ indicates that this file contains the raw data .
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(ix) Under Output, click the Options button (Fig. 2A). In the ‘Options for unicsv’ window (Fig. 2B)
check the GPS datum (def. WGS 84 box and type ‘WGS 84’ into the adjacent white space. Also
check the Write position using this grid. box and type ‘UTM’ into the adjacent white space. Also
check the Write timestamps with offset x to UTC time button and type ‘-4’ into the adjacent white
space (Note: after November 1, 2015 at 2:00 am local time, the UTC offset for Princeton will be
-5, because of daylight savings time. In Spain and France, the UTC offset is +1 until October 25,
and +0 after October 25, 2015 at 4:00 am local time). Click the OK button to close this GUI, and
you will see the text datum=WGS 84,grid=UTM,utc=-4.format=0,filename=0 written next to the
Options button under Output in the GPSBabel GUI (Fig. 2A).

(x) Now, click the Apply button in the bottom left of the GUI (Fig. 2A). After about three lines of
code, you should see the message ‘Translation successful’ appear in the large white box above the
Apply button.

(xi) You now should see your data file in the appropriate folder.

Now, once you have the data downloaded from your Garmin GPS unit, you can edit the file until it is ready
to use for lab02a,b.

(A) Open ‘netidl02a Braw.csv’ in Microsoft Excel. You will see a spreadsheet with the following 10 column
headers: No, UTM-Zone, UTM-Ch, UTM-East, UTM-North, Name, Altitude, Description, Symbol,
State.

(B) You will note that the ‘Decsription’ column contains the date and time stamps for your waypoints. You
will need to divide this column into multiple columns using the Excel Data → Text to Columns... tool.

(i) Select the entire column H (Description) in your netidl02a Braw.csv spreadsheet. Then choose
Data → Text to Columns...

(ii) In the Convert Text to Columns Wizard – Step 1 of 3 GUI, choose the Delimited radio Button, and
then click the Next > button.

(iii) In the Convert Text to Columns Wizard – Step 2 of 3 GUI, check the box next to Space. Also, check
the box next to Other and write ‘/’ (just the slash, not the quotation marks) in the adjacent white
space. Also keep the default check mark next to the Treat consecutive delimiters as one. Then click
the Next > button.

(iv) In the Convert Text to Columns Wizard – Step 3 of 3 GUI, select the first column (Description) in
the Data preview window (it will get highlighted black) and choose the Text radio button from the
Column data format section in the upper right. Then click the Finish button. Click OK when it
asked if you want to replace the contents of the selected cells?

(C) Now, you will see that the dates have been separated nicely into month, day and year columns. However,
the time column still contains hours, minutes and seconds altogether, separated by colons.

(i) Select the entire column K (with the time data) in your netidl02a Braw.csv spreadsheet. Then
choose Data → Text to Columns...

(ii) In the Convert Text to Columns Wizard – Step 1 of 3 GUI, choose the Delimited radio Button, and
then click the Next > button.

(iii) In the Convert Text to Columns Wizard – Step 2 of 3 GUI, check the box next to Space. Also, check
the box next to Other and write ‘:’ (just the colon, not the quotation marks) in the adjacent white
space. Also keep the default check mark next to the Treat consecutive delimiters as one. Then click
the Next > button.

(iv) In the Convert Text to Columns Wizard – Step 3 of 3 GUI, select the first column in the Data
preview window (it will get highlighted black) and choose the Text radio button from the Column
data format section in the upper right (you will see the word ‘General’ get replaced by the word
‘Text’ in the column header). Then click the Finish button. Click OK when it asked if you want
to replace the contents of the selected cells?
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Figure 2: Screenshot of the GPSBabel GUI. (A) shows the main GUI and the recommended options outlined
above. (B) depicts the Output Options GUI and the recommended options outlined above.

(D) You are almost there, but you will see that some of your times are AM and some are PM. You need to
switch to 24-hour time so that your spreadsheet does not contain any letters.

i Highlight all of column K. Then choose Insert → Columns. You will see a blank column appear in
between the Year and Hours columns (note that if you are getting confused about which column is
which, just add headers as you go through the text to columns operations).

ii Click the cell in the second row of column K (i.e., right below the header). Now you will write a
formula in the cell. Type ‘=IF(ISNUMBER(FIND(“AM”,O2)),L2,(L2+12)). This command looks
at row 2 in column O – if it is AM, then it prints the value from the hours cell L2 as it is. If it
finds PM in cell O2, then it adds 12 to the value in L2 to convert hours to 24-hour format, and then
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prints the new hours value in cell K2. Click return on your keyboard when you are done writing
the formula.

iii Now, select the cell K2 that you just edited by clicking it once. The cell will become outlined in
blue, where the bottom right corner is a tiny, blue-filled box. Click that box and hold the mouse
button down as you drag the K2 formula down so that it applies to the entire K column.

iv Select the entire K column and choose Edit → Copy. Then, select just cell K1 and choose Edit →
Paste Special. From the Paste Special window, click the radio button labeled Values, and then click
OK. This step replaces the cells with numerical values, rather than a formula that depends on other
columns.

v Now select all of column L and choose Edit → Delete. Delete columns N and O as well.

vi Now you should have a nice spreadsheet with month, day, year, hours (in 24-hour format) and
minutes, all separated into different columns.

(E) Next, open ‘template.csv’ and do a File→Save As. Choose ‘.xlsx’ as the file format, navigate to your
‘/Users/netid/frs135/Labs/lab02a’ directory, and rename this file ‘netidl02a B.xlsx’.

(F) Copy the data from the relevant columns in ‘netidl02a Braw.csv’ to the appropriate columns in ‘netidl02a B.xlsx’.

(i) The ‘Name’ column data from ‘netidl02a Braw.csv’ gets pasted into the ‘WP’ column from ‘netidl02a B.xlsx’.

(ii) The ‘UTM-zone’ column data from ‘netidl02a Braw.csv’ gets pasted into the ‘UTMz’ column from
‘netidl02a B.xlsx’.

(iii) The ‘UTM-East’ column data from ‘netidl02a Braw.csv’ gets pasted into the ‘East’ column from
‘netidl02a B.xlsx’.

(iv) The ‘UTM-North’ column data from ‘netidl02a Braw.csv’ gets pasted into the ‘North’ column
from ‘netidl02a B.xlsx’.

(v) The ‘Altitude’ column data from ‘netidl02a Braw.csv’ gets pasted into the ‘Elev’ column from
‘netidl02a B.xlsx’.

(vi) Then paste all your nicely separated month, day, year, hours, and minutes columns ‘netidl02a Braw.csv’
from into MM, DD, YYY, hh, and mm from ‘netidl02a B.xlsx’, respectively.

(G) You will notice that the Garmin does not record all of the information you need to complete the
spreadsheet. You will have to return to your notes and enter into Excel fields like CP(L), Paces, ∆XY,
GPSelev, Acc, Sats and Met.

(H) Now save your ‘netidl02a B.xlsx’ file – it is done for now. Then, delete row 1, so that all the headers are
gone and not a single letter remains in your entire spreadsheet (it can only contain numbers). Choose
File → Save As. In the window that pops up, navigate to your ‘/Users/netid/frs135/Labs/lab02a’
directory and name the new file ‘netidl02a B.csv’. Under Format, choose the Comma Separated Values
(.csv) option from the pull down menu. Click Save. When the window pops up saying ‘This workbook
contains features that will not work or may be removed if you save it in the selected file format. Do
you want to continue’, the answer is yes, so click the Continue button.

(I) When you go to close this spreadsheet, a window will popup asking ‘Do you want to save the changes
you made to “netidl02a B.csv”?’ Excel is asking you this because you saved it as a .CSV rather than a
.XLSX file. Unless you have changed something, click the Don’t Save button.
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4 GARMIN GPS Setup

For the General setup:

• Press the MENU button twice

• Choose SETUP

• Choose TIME

• Set TIME FORMAT to 24 HOUR, and set TIME ZONE to US - EASTERN

• Go back to the SETUP menu by pressing the PAGE button

• Choose UNITS

• Set position format to be UTM UPS

• Set Map Datum to WGS84

• Set Distance/Speed to METRIC

• Set Elevation to METERS (m/sec)

• Return to the SETUP menu and choose DISPLAY

• Change the DISPLAY MODE to be DAYTIME

• Return to the SETUP menu and choose TONES

• Change the KEY BEEP to OFF

For Track Log setup:

• From the SETUP menu, choose TRACKS

• Turn ON the track log

• Choose the SETUP button from the TRACK menu

• Uncheck the WRAP WHEN FULL box

• Set RECORD METHOD to AUTO with INTERVAL = MORE OFTEN. You may decide to change
this to a specific DISTANCE or TIME interval, or set to more or less often, depending on how quickly
your track log is filling up.

5 Caring for your GPS

You are responsible for not losing or damaging any of the GPS equipment. These units remain
the property of Princeton University.

Each of you will be assigned one GPS unit (labeled with capital letters) to care for until the end of the
semester. In case of loss, damage or theft of any equipment, you are responsible for replacement costs:

Garmin GPSMap 60cx $400
GPS USB Cable $20
GPS Case $20

In six years of teaching this class, only one student lost a GPS.
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