
GIS I - Exercise 3 (AV9.2) - Map Rainfall in 3D with Spreadsheets (v2d, Jun 2010) 
 
Desired Learning Outcomes: 
 Retrieve a set of state boundaries from pre-packaged ESRI data 
 Use the query builder to reduce the state set to New Jersey 
 Make a new Theme of points (hypothetical rain gauge stations located on a lat-long grid in 

New Jersey) both manually (OSD) and automatically (Add Event Theme) 
 Join an external spreadsheet with rainfall amount to the attribute table of the rain gauges 
 Label the points with the rainfall amounts 
 Create a 3D model and contour map of the rainfall with ESRI’s 3D Analyst Extension 
 
Before Proceeding – Create a separate folder for Exercise 03 titled *_Exr03 (where *= your 
name), within your own personal GIS I class folder, in order to keep your files well-organized.  
Make sure that you download and/or save new themes to this folder. Failure to do this could 
result in software failure and/or loss of your data. 
 
Part I – Build a map and add point shapefiles through “OSD” and “Add Event Theme” 
Step 1 - Copy GIS data to your folder 
Discussion - This exercise will begin with a theme (aka shapefile) of U.S. states that you will 
reduce to just NJ by means of “querying”.  To prevent corruption or disruption of these data files, 
you MUST first copy these files to your own Exr03 folder.  NOTE: you MUST copy ALL 
components of GIS themes, not just the *.shp component. 
Procedure – 
-  Make sure your own Exr03 folder is visible on your computer screen. 
- If you are onsite (GIS Lab), scroll to gisstudent\GIS_I_Exercise_Data\gis_I_exr03_input_data. 
- If you are online, open Internet Explorer; use our FTP protocol to connect to the NJCU server 
and scroll to ftp://geosrv.njcu.edu/GISStudent/GIS_I_Exercise_Data. NOTE: You cannot click 
on the preceding “ftp:” line and use it as a complete link because the server is secure.  If the line 
does act as a link, finish the FTP sign-in procedure per “FTP protocol” to access the folder. 
 Dbl-click on GIS_I_Exr03_input_data. Make sure there are 7 files in the folder that opens: 

 
 Copy (DO NOT CUT!) and Paste all of the contents of this folder to your own Exr03 folder. 
NOTE: One GIS student working long-distance said she was unable to select all the files and 
Copy>Paste them all at the same time.  She had to copy and paste each one of these files 
separately. 
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http://faculty.njcu.edu/wmontgomery/NJCU_GIS_I/connect_to_njcu_server_via_ftp_v6.pdf
ftp://geosrv.njcu.edu/GISStudent/GIS_I_Exercise_Data


Step 2 -  Start ArcMap, set Layer properties 
Procedure: 
 Open Arcmap (Start > ArcGIS > ArcMap).  An ArcMap window appears: 

 
 Select “a new empty map” (red arrow above).  An empty map window appears (below left): 

  
 Rt-click on Layers in the Table of Contents (ToC); select Properties (above right): 
A Data Frame Properties window appears.  Select the Coordinate System tab: 

  
 Under “Select a coordinate system” (above left), select Predefined > Geographic 

Coordinate Systems > North America > North American Datum 1983 (above right) 
 Press Apply, OK.  The ArcMap Data View re-appears: 
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Move your mouse around in the map window.  X,Y coordinate values (possibly expressed in 
unknown units) in the lower RH portion of the ArcMap window (red arrow above) change as you 
move the mouse N,S,E,W in the window.  We will specify decimal degrees (DD) for these 
coordinates after we add the states theme. 
 
Step 3 - Bring the states theme into ArcMap, isolate New Jersey as a new layer 
Procedure: 
 Press the Add Data button       in ArcMap.  An Add Data window appears with icons across 

the top.  Take your mouse pointer and let it rest on each of these icons for a few moments.  
The “name” of each icon appears.  Select the Connect to Folder icon (below left): 

   
 Scroll to your Exr03 folder via the Connect to Folder window.  When you reach your folder, 

press the OK button to actually open the folder (I have been unable to open the folder by 
double-clicking).  The states.shp file will appear (above right): 

 
Discussion:  Note: Do NOT Panic if you only see the “*.shp” file, rather than the 7 that you 
copied into this folder earlier.  The reason that you see only this component is because this is 
the “feature” component of the theme (showing the actual point, line, or polygon), and is the only 
component that automatically appears in the Data View window.  The only other component that 
can be made visible is the attribute table (“*.dbf” file), and that component appears only when 
you “open attribute table”. 
 
Procedure: 
 Select states.shp one of two ways: single click and press Add, or double-click.  States.shp 

should appear in the ArcMap window.  Notice that all the US states are shown: 
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We don't need all the states. But we do want the outline of NJ as our map area. 
 Rt-click States in the Table of Contents (ToC) (above right); Select Open Attribute Table: 
The states attribute table appears, with the attributes ESRI has included as pre-installed data.   

 
Discussion:  You will use the states attribute table and a query to isolate New Jersey.   
Procedure: 
 From the states attribute table, press Options (red arrow above) > Select by Attributes 

(below left): 

  
The “Select by Attributes” window appears (above right): 
 
You will create a query to separate New Jersey from the rest of the states: 
 In the “Method”: window, select “Create a new selection” 
 In the “Select * from States Where”: window, build your query with your mouse as follows: 

- Dbl-click on “State_Name” in the Fields: window. 
- Single-click the = button. 
- Press “Get Unique Values”, scroll to and select, “New Jersey” from the list that appears. 
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The window should look as below: 



 
NOTE:  If there are elements missing, re-do the query until it reads as above. 
 Click Apply.  In the map window, New Jersey is outlined in bright aquamarine blue: 

 
If you can’t see NJ, select the   +   magnifying glass from your tool bar (red arrow above) and 
magnify NJ until you can see it. 
 Activate the attribute table (make the upper header of the table blue by selecting it), and 

scroll to New Jersey.  The row is highlighted in the bright blue outlining NJ on the map: 

 
ArcView provides an intuitive message to the user: This highlighted row of data is associated 
with the map object (the polygon representing New Jersey) that is highlighted in the same color. 
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 Rt-click on States in the ToC; select Data > Export Data (left below). An Export Data screen 
appears (below right); you want to Export Selected Features, using the same coordinate 
system as the Data Frame.  Select the Browse button (red arrow). 

  
 Scroll to your Exr03 folder (below left). DO NOT use the Export_Output.shp default name; 

instead, type New_Jersey.shp (below right) and press Save. 

   
 When the Export Map window returns (not shown), press OK; press Yes to add the data. 
A new theme, entitled New_Jersey appears in the ToC and in the map window (below left).  
Turn off States (uncheck the small box in the ToC); States becomes invisible and New_Jersey 
becomes the only visible theme in the Data View (below right) 

       

Uncheck small box to turn layer off 
without removing it. 
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Discussion:  We want to change New Jersey from a solid polygon to an outline.   
Procedure: 
 Left-click the polygon below New_Jersey in the ToC. Select Hollow in the table that opens 

(left below); notice that “Fill color” becomes blank, but there is still an outline color.  Select 
the arrow next to the outline color in order to see a palette of colors (below right), select red.  

     
 Increase the outline width from 0.40 (below left) to 2.0 (below right); press OK.  

   
NJ appears as hollow with a red outline on the map (below).      
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 If you have not yet done so, select File > Document Properties > Data Source Options >  
Store relative path names to data sources .  Also, check, “make relative paths the default…”; 
press OK, twice. 

 Select File > Save As; Scroll to your folder and name your mxd something memorable, like 
Yourname_Exr03.  Press Save. 

 
Step 4 - Set the View Units from Degrees-Minutes-Seconds to Decimal Degrees. 
Discussion – Because data sets frequently are in different coordinate systems, GIS users 
need to be aware of different coordinate systems and how they relate to each other. For 
example, an analogy for degrees-minutes-seconds (DMS) and decimal degree (DD) coordinate 
systems can be drawn from a clock.  You can write 6:30 A.M. as 06:30:00 (i.e., 6 hours, 30 
minutes, zero seconds).  Another way to express 6:30:00 could be 6.50 (in decimal hours).  
One system uses hours-minutes-seconds, while the other uses decimal fractions of hours, but 
the actual time remains the same.  Likewise, either a DMS or a DD coordinate system can be 
used to locate the same point in space.  Let’s use ArcMap to look at an example.  First, 
observe your map: 

 
Note the “Unknown Units” on the bottom right of the map window. 
 Rt-click on Layers in the Table of Contents (ToC) > Properties > General tab.  In Data 

Frame Properties, notice that the Units > “Map” window contains a grayed-out Decimal 
Degrees, reflecting the predefined map units that are embedded in this theme.   

 In the “Display” window under “Units:” select Degrees Minutes Seconds; click Apply: 
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Press Apply, OK. 



The units on the map have changed from Unknown to Degrees (o), Minutes (‘), Seconds (“): 

 
I have drawn a rectangle at a spot that is located at 74o30’ West and 39o30’ North (below): 
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When I change the coordinate system to DD (Decimal Degrees), the same point is now located 
at -74.5 39.5 Decimal Degrees (below).  

 
On an X-Y graph, -74.5 would be the X-coordinate, and 39.5 would be the Y-coordinate, and the 
(X,Y) pair would be represented as (-74.5, 39.5) (below). 
               Y North 
       +100 
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   -  100     + 100     
 
 
 
 
 
         -100 
Set your map coordinate system units to be Decimal Degrees.  Move the mouse over New 
Jersey. Note that the coordinates are now in decimal degrees.  Why is it that the X coordinate is 
negative? The answer lies in what you (hopefully) learned in middle school geometry class: all 
the numbers above and to the right of (0,0) in a Cartesian coordinate system are positive, 
whereas all the numbers to the left and below (0,0) are negative.  Degree designation in GIS 
makes sense when you define the intersection of the Equator and the Prime Meridian as (0,0).  
The Prime Meridian (PM) runs through Greenwich, England.  New Jersey is west of the PM, to 
the left of it in map view.  Therefore, any units of measurement along the X-axis (longitude) in 
NJ are negative. 



 
Step 5 - Create a new attribute table and point theme for rainfall gauging stations - 
Discussion:  You will now perform onscreen, manual digitizing of 10 points to create a new 
theme that represents the locations of 10 rainfall measurement gauges in New Jersey.  You will 
learn how to do this in a faster, more automated manner later in the exercise. 
Procedure: Recall from Exr01 that you must use ArcCatalog to create (and name) an empty 
shell of a shapefile before you start filling it with points.   
 Open ArcCatalog by dbl-clicking on the yellow file cabinet at the top of ArcMap, or by going 

to Start > Programs > ArcGIS > ArcCatalog.  A Windows Explorer-style window opens.  
Using the left window, scroll to your Exr03 folder; double-click on it to open it. Your current 
GIS shapefiles in your folder appear in the RH window: 

 
 At the top bar of ArcCatalog, select File > New > Shapefile (above left).  A Create New 

Shapefile window appears (below left), with a default shapefile name in the Name: window: 

    
 Type rain_gauge_locs_manual in the Name: window (above, right).  Feature type = point. 

Select Edit button and set the coordinate system to: Geographic coordinate systems (GCS) > 
North America > North American Datum 1983.prj. Press Add (below), then Apply, OK. 
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Press OK when the Create New Shapefile window returns (below left). ArcCatalog returns, with 
the shapefile in the RH window (below right) 

     
 
Discussion: Make sure you have both the ArcCatalog and ArcMap windows open, small 
enough so they are both visible on the screen: 

  
Make sure that the “Display” tab (NOT “Source” tab) at the bottom of the ToC is active. 
 Copy and paste (or drag) the rain_gauge_locs_manual.shp icon from ArcCatalog into the 

ToC of ArcMap.  If a “one or more layers are missing spatial reference information” window 
appears, it means that you did not set the coordinate system in the new shapefile properly.  
Repeat the above steps to correctly set the shapefile’s coordinate system to GCS NAD 
1983.  Consult your instructor if you are unable to get past this step. 
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 Once you have copied the rain_gauge_locs_manual.shp over to ArcMap, close ArcCatalog. 
 If necessary, drag the rain_gauge_locs_manual.shp to the top of the ToC to ensure your 

ability to see the points you create: 

   
 Select rain_gauge_locs_manual.shp (it will turn dark blue in the ToC).  Go up to View-

Toolbars, and make sure the Editor toolbar is checked        (red arrow below): 

 
 Select the black arrow next to Editor       and select Start Editing from the drop-down menu: 
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A Start Editing window may appear that asks which folder or database you want to edit: 

 
 Select the folder that contains rain_gauge_locs_manual.shp (red arrow above); click OK. 
 
Before going any further, MAKE SURE that: 

 1) Create New Feature is in the “Task” window (red arrow below) and  
 2) rain_gauge_locs_manual.shp is in the “Target” window  (blue arrow below): 

 
 Click on the black arrow      to the right of the red & yellow pencil to the right of Editor (green 

arrow above): 
 Click on the pencil again if it appears in a small box.  This puts AV into “create a new 

feature” mode and will enable you to use the pencil to draw a point that will be saved as a 
feature on the map and in the rain_gauge_locs_manual.shp attribute table. 

 
Step 6 - Perform onscreen digitizing of 10 points 
 Discussion: You will now manually perform “onscreen digitizing” (OSD) of the following 10 

rain gauge stations by using a point to locate each station.  Each time you digitize a point, 
you will also type in the ID number for that point in the ID column of the attribute table. 

ID Longitude(oW)  Latitude(oN)     
1 -75.00   41.00 
2 -74.50   41.00 
3 -74.00   41.00 
4 -75.00   40.50 
5 -74.50   40.50 
6 -74.75   40.75 
7 -74.25   40.75 
8 -74.75   40.25 
9 -74.25   40.25 
10 -75.00   40.00 
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Procedure:  
 Open the rain_gauge_locs_manual.shp attribute table (right-click on the theme name in the 

ToC > Open Attribute Table).  The attribute table already has FID, Shape, and ID fields: 

  
 Set the map scale to 1:500,000 or even larger (smaller number) if necessary.  Use the 

mouse to find the location of the first point by following the lat-long coordinates in the lower 
RH portion of the screen (red arrow below): 

 
Select the hand on the toolbar and drag the map to a new location if necessary.  Click on the 
red & yellow pencil to re-enter the editing mode. 
 Move the mouse to your first point (-75.00, 41.00) and left-click.  A bright, aqua-blue point 

should appear on the map, and a new line in bright blue should appear in the attribute table: 

 
 Select the ID entry (0) and type 1 (red arrow below): 
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Press Enter on your keyboard to save the ID entry. 
Move to the next point (-74.50, 41.00), digitize the point and enter the ID value (2) in the AT: 

 
Select Editor > Save Edits periodically during the digitizing process.  When you have finished 
all 10 points, select Editor > Save Edits and finally Editor > Stop Editing.   
 File > Save to save your project. 
 
Step 7 - Create 30 rain gauge station points in MS Excel 
Discussion:  Arcview can recognize columns of X,Y data in tables and automatically plot 
points, which can be a much faster way to create a large number of points than manual 
digitizing.  You will create a table of 30 rain gauge data points in MS Excel and save it as an .xls 
(Excel) file.  You will then save it as a .dbf (dBase) file because AV can not read MS Excel.   
Procedure: 
 Open a new MS Excel workbook or worksheet.  A blank spreadsheet appears: 

  
 Type these column headers in the first row:  
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NOTE: No empty columns or rows in this spreadsheet! If names are too long for an initial 
column width, simply make the column wider (use Help if necessary). 
 Type in values from 1 to 30 in the ID column: 

 
Discussion: It is CRITICAL to format the latitude and longitude columns for 2 decimal places.  
Otherwise, the lat-long values will be automatically rounded by Excel to whole numbers, which 
will cause a number of points to “overplot” on top of each other. 
Procedure: 
 Select the B and C column headers (columns selected in blue); select Format > Cells  

 
The Format Cells window appears; select Number under “Category:” and 2 in “Decimal places” 

 
 Press OK 
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 Enter the following latitude and longitude data into the spreadsheet: 
ID  Lon_degrees  Lat_degrees     
1  -75.00   41.00 
2  -74.50   41.00 
3  -74.00   41.00 
4  -75.00   40.50 
5  -74.50   40.50 
6  -74.75   40.75 
7  -74.25   40.75 
8  -74.75   40.25 
9  -74.25   40.25 
10  -75.00   40.00 
11  -74.50   40.00 
12  -75.25   39.75 
13  -74.75   39.75 
14  -74.25   39.75 
15  -75.00   39.50 
16  -74.50   39.50 
17  -74.75   41.00 
18  -74.25   41.00 
19  -75.00   40.75 
20  -74.50   40.75 
21  -74.75   40.50 
22  -74.50   40.25 
23  -74.75   40.00 
24  -74.25   40.00 
25  -75.00   39.75 
26  -74.50   39.75 
27  -75.25   39.50 
28  -74.75   39.50 
29  -75.00   39.25 
30  -74.75   39.25 

 When you've finished entering the data, select File-Save As; A Save As window appears:   

 
Fill it in as follows: 

o Save in:  (browse to your Exr03 folder on your computer or on the server) 
o File name: rain_gauge_locs_auto.xls 
o Save as type: Microsoft Excel Workbook   

IMPORTANT:  
1) Make sure you save this Excel spreadsheet inside your Exr03 folder!  
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2) Use underscores (_) between file name words to avoid error messages later. 



 
Discussion:  Since Arcview may not read Excel files, you now need to re-save this Excel file in 
dBase IV (.dbf) format.  Make sure you first select an active cell in the worksheet (e.g., A2).  
Select File – Save As. A Save As window appears: 

 
 In the upper “Save In: ”window, make sure  you browse to inside your Exr03 folder.   
 In File Name:, leave the same file name (rain_gauge_locs_auto)   
 In the lower window, Save As Type, scroll to and select dBase IV, then click SAVE.  

Excel will present a warning:  
”The selected file type does not support workbooks that contain multiple sheets.  To save 
only the active sheet; Click OK “.  Click OK.   
 
Excel presents another warning: “rain_gauge_locs_auto.dbf may contain features that are 
not compatible with DBF 4. Do you want to keep the workbook in this format?”   Click Yes.  
Click X in the upper RH corner of the spreadsheet to close your .dbf file.  Excel will ask “Do 
you want to save the changes you made? “  Click NO (you already saved the file).  

 
Step 8 - Add X-Y (lon-lat) data and automatically create a new point theme 
Discussion: In ArcMap, longitude and latitude are interpreted as “X” and “Y” values in a 
coordinate system, as depicted below:   
 
           (+)    North 
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  Y - axis            (-)          (+) 

             Field 
            Values                                        (0,0) 
          (latitude) 
 

      (-) 
 

 
ArcMap can read the longitude-latitude values from rain_gauge_locs_auto.dbf and 
automatically plot those values on a map much faster than you can plot manually. 

X - axis field values (longitude) 



Procedure:  
 From the ArcMap upper menu bar, select Tools > Add XY data: 

 
An Add XY data window opens: 

   
 Select the folder on the RH side of the “Choose a table…” window and browse to your Exr03 

folder and select rain_gauge_locs_auto.dbf.  The Add XY Data window returns: 
rain_gauge_locs_auto is in the “Choose a table…” window, LON_DEGREE is the X field, 
and LAT_DEGREE is the Y field. Notice that the Description says the file has an “unknown 
coordinate system”.  Select Edit and set the coordinate system to GCS North American 
Datum 1983.prj (as you did earlier when adding rain_gauge_locs_manual.shp). Click Apply, 
OK. 
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The coord system is now GCS_North_American_1983 (below, left). Press OK. 

  
A layer of 30 points, rain_gauge_locs_autoEvents appears (above, right). 
NOTE: If there are NOT 30 points, or the points do not appear EXACTLY in the positions 
shown, you either mis-entered data or formatted the lat-long columns of the original Excel 
spreadsheet incorrectly.  You must return to that step and perform it correctly. 
 Rt-click on rain_gauge_locs_autoEvents > Open Attribute Table.  It appears with Latitude, 

Longitude, FID, ID, and Shape columns (below): 

 
Don’t panic if the X and Y values do not all show 2 decimal places; AV has chopped off 
unnecessary zeroes.  If you formatted the original Excel sheet correctly to 2 decimal places, 
each one of the 30 points will plot correctly, as in the map above. 
 Use File > Export to create a JPG of your map, and send it to your instructor. END PART I. 
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Part II – Perform a “Table Join” and create both a map (mxd) and 3D image (sxd) 
Step 1 - Create an external “rainfall” spreadsheet to join to “rain_gauge_locs_auto” 
Discussion:  One of the most powerful features of a GIS is its ability to “join” external 
spreadsheets and databases to internal attribute tables.  This enables mapping ALL the 
attributes from the “joined” table, even though this table is not “in” a GIS per se.  In this next 
step, you will create a spreadsheet of measured rainfall data taken from each of the 30 rain 
gauge stations that you just plotted. 
Procedure:   
 Open MS Excel, and set up a spreadsheet with two columns of data - ID and 2004_Rain_in. 
 Enter the following data: 

  
When you are done entering the data, save this table first in .xls and then in .dbf format, like 
you did earlier for rain_gauge_locs_auto.  Refer to those steps if necessary.  Save the 
tables in your Exr03 folder with a name you can remember, such as 2004_rainfall_in.  
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Step 2 - Join rainfall data to the rain gauge locations 
Discussion: In order for one table to be joined to another, the tables must share a common 
field (column) known as the “primary key”.  There are various types of joins, but the one you 
want to perform here is “one-to-one”, because you want one 2004 rainfall amount value to 
be associated with one (and only one) rain gauge. The primary key will be ID. 
Procedure:   
 In ArcMap, select the Source tab at the bottom of the ToC. 
 Select File > Add Data, scroll to your Exr03 folder, and add 2004_rainfall_in.dbf: 

 
 In ArcMap, rt-click on rain_gauge_locs_autoEvents  > Joins and Relates > Join: 

 
A Join Data window appears: 

   
Fill in the blanks:  “What do you want to join to this layer?”  Join attributes from a table 

1. Choose the field in the layer that the join will be based on:  ID 
2. Choose the table to join to this layer: 2004_rainfall_in 
3. Choose the field in the table to base the join on: ID.  Click OK. 
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If you are asked to Create an Index (below), say No (but it probably does not hurt to say Yes).  

 
 In ArcMap, rt-click on rain_gauge_locs_autoEvents in the ToC > Open Attribute Table.  
Notice that there are additional fields in the attribute table: 

 
The source of the field can be determined by the prefix (rain_gauge_locs_auto_Features and 
2004_rainfall_in).  The unique identifying number that is the same for each row is ID. 

 
Step 3 - Convert rain_gauge_locs_auto Events to a shapefile 
Discussion:  To preserve your points, it is wise to convert this “events” theme to a shapefile. 
Procedure:  In the AV ToC, rt-click on rain_gauge_locs_autoEvents > Data > Export Data: 
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An Export Data window appears: 

    
In the Export Data window, select All Features, and “Use the same Coordinate System as: the 
data frame”.  In the “Output shapefile or feature class” window, browse to your Exr03 folder, and 
type rain_gauge_locs_with_rain.  Press Save. Press OK when the Export Data window returns.   
 Press Yes when prompted by this window: 

 
The points should directly overlie those of rain_gauge_locs_autoEvents; if so, rt-click > Remove 
rain_gauge_locs_autoEvents. 

 
 File > Save your project. 
 
Step 4 - Label each rain gauge station with 2004_rainfall_in 
Discussion:  Prior to construction of a 3D model and contour mapping of rainfall, it is wise to 
label each gauging station with the 2004 rainfall recorded at that location, since this is the data 
that will be used to construct the model and create the contours. 
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Procedure: Rt-click on rain_gauge_locs_with_rain in the ToC > Properties. Select the Labels 
tab and fill in the Layer Properties window with the following information:   
 Check “Label features in this layer”.   
 Method: Label all features the same way 
 Label field: 2004_RAIN_ (AV truncates 2004_rain_in to 10 characters maximum) 

 
 Click Apply, OK.  
The 2004 rainfall amount appears to the upper Right of each rain gauge station point: 

 
 File > Save your project  to your Exr03 folder 

 
Step 5 - Create a triangulated irregular network (TIN) with 3D Analyst 
Introduction: 3D visualization of “continuous surfaces” and the companion ability to represent 
these 3D surfaces in 2D are very useful skills because they allow you to interpret (“map”) data 
and communicate those interpretations to a wide audience.  An example of a continuous 
surface is the Earth’s surface, which is 3D in nature.  This 3D surface can be represented in 2D 
by creating a map of points, each with an attribute of elevation above sea level,  and then 
drawing “isolines” (“iso” means equal) to connect equal elevation values.  Hills and mountains 
are typically contoured as “closed highs” extending above sea level, whereas ocean basins are 
“closed lows” extending below sea level.  In the same manner as you represent the Earth’s 
surface in 3D or 2D, you can represent New Jersey’s 2004 rainfall by creating a 3D model and 
creating a 2D contour map.  If you need further background on continuous surfaces and contour 
mapping, consult your text, use Google, or ask your instructor to show you a U.S. Geological 
Survey topographic quad map. 
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Discussion: Triangulated Irregular Networks (TINs) are models of 3D surfaces that AV creates 
from vector point data.  AV treats a user-defined attribute (e.g., elevation above sea level or 
2004_rain_in) as a “z-value” (“elevation value”) in X-Y-Z space, then it uses the simplest forms 
of planes (triangles) to connect these z-values together into a continuous surface.  The TIN can 
then be displayed in 3D.  It also serves as a surface which can be contoured in 2D. 
Procedure:  
 Select Tools > Extensions.  On the window that appears, make sure that 3D and Spatial 

Analysts are checked.  Press Close. 

  
 Select View > Toolbars; confirm that 3D Analyst and Spatial Analyst are checked  

 

3D Analyst 

Scroll to Spatial Analyst 
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 Click on 3D Analyst      toolbar > Create/Modify TIN > Create TIN from features: 

 
 A “Create TIN from Features” window appears (below left): 

   
Make the following changes (above, right), to the window: 
 Check  the box next to rain_gauge_locs_with_rain. 
In the Settings for Selected Layer panel, choose the following settings: 

o Height Source: 2004_RAIN_ 
o Triangulate as: Mass points 
o Tag value field: ID 

 In the Output TIN window, NOTE the following departure from protocol: 
Many users have reported trouble in creation and display of TINs.  In-lab GIS students rarely 
have trouble. My own (limited) experience suggests that if there is a space ANYWHERE in the 
directory path from the drive letter (e.g., C: or G:) to the tin folder, the TIN will not be created.  
Therefore, I suggest that online GIS students place the tin in the main C drive folder of their 
home computer: 

 
 Press Save. 
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The TIN (a polygon with different colors in a “stripe” pattern) should appear: 

 
If not, check your settings and directory path.  If the settings and path look OK, contact your 
instructor right away, rather than spend hours (literally) trying to troubleshoot the problem. 
 
Step 6 - Modify the class breaks on the TIN to correspond with contour values. 
Discussion: The TIN is a 3D model that uses colored bands to distinguish ranges of values, in 
this case, 2004 rainfall. 
Procedure:  
 Rt-click on tin_* (where * is your name) in the ToC > Properties > Symbology.  In the lower 

left part of the window, uncheck “show hillshade illumination effect” (red arrow below): 

   
 Press Apply, OK.  You now see the full range of TIN colors in the Data View (above right) 
 Rt-click on tin_* > Properties > Symbology.  Layer Properties window re-appears: 

    
In the upper RH Classification window, select the Classify button (red arrow above left).  A 
Classification window opens (Right above.)  In the “Method” window, select Defined Interval, 
and set the “Interval Size” to 5.  Click OK in the lower RH corner of the window. 
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The Layer Properties window returns (below, left). 

   
The breaks that separate the colors are now in increments of 5 inches of rainfall.  If you don’t 
care for the default colors, select a “Color Ramp” that is pleasing to you.  Press Apply, OK. 
The Data View returns with the TIN color-coded according to your specifications (above, right). 
 File > Save your project. 
 
Step 7 - Display the TIN in 3D in ArcScene 
Discussion: ArcScene is part of the ArcView package (along with ArcCatalog and ArcMap).  It 
enable you to bring 3D files into a view, then manipulate them in order to aid 3D visualization. 
Procedure:   
 Select Start > Programs > ArcGIS > ArcScene. An empty ArcScene window opens: 

   
Select File > Add Data or press the Add Data button.  Scroll to your tin_* folder and select it.  
The TIN appears, but in a very distorted manner (see above right). 
 Select View > Scene Properties: 
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The Scene Properties window appears: 

    
 Select the General tab (above, left).  Next to the “Vertical Exaggeration” window, press 

Calculate from Extent (red arrow above left).  A number will appear in the “Vertical 
Exaggeration” window (blue arrow, above right).  Press Apply, OK.  The TIN should look 3D 
in ArcScene (NOTE: you will probably have to select the Navigate button        (red arrow 
below left), then rt-click and drag the mouse toward you in the View to increase TIN size. 

    
 Rt-click on the TIN in the ToC > Properties > Symbology.  In the Layer Properties window 

(below left), select Remove > Faces, then select Add > Face elevation with graduated color 
ramp (below right); click Add, then Dismiss 
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As you did earlier, press the Classify button, and you are taken to a second screen (below).   

   
In the Method window, select Defined Interval and set the Interval Size = 5. Press OK. 
Uncheck “Show hillshade illumination effect…” (red arrow above right).  Press Apply, OK.  The 
ArcScene returns with a color-coded 3D model, with color bands representing each 5” of rainfall: 

 
To maximize the 3D effect, select the Navigator button, then press and hold the Right mouse 
button and pull the mouse toward you. The image gets larger. Press and hold the Left mouse 
button and the image will start rotating about various axes, allowing you to move the image 
around in 3D space.  Move the image to a position where you are looking at the side of the TIN, 
with the lines separating the 5-inch intervals approximately horizontal.  This will help you see 
how contour lines are created in the next step. 
 Select  File > Document Properties > Data source options > Store relative path names; 

click OK, Apply, OK 
 Select File > Save As, scroll to your Exr03 folder and save the Scene as Exr03_3D.sxd. 
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Step 8 - Create contours of NJ rainfall with 3D Analyst based upon the rainfall TIN 
Discussion:  The color breaks at every 5” of rainfall on the TIN wrap all the way around the 
TIN, except for the north end.  You can see these breaks easily in 3D in ArcScene.  In ArcMap, 
you can only view the TIN from a “map” view (directly from above).  From above, the only places 
you see color changes are where the 5-inch increments intersect the outer surface of the TIN.  
To illustrate this, arrows are placed at a spacing of every 10” of rainfall on the cross-section 
below, at the spot where the line representing a certain value of rainfall (e.g, 20”) intersects the 
outer surface of the TIN.  These “isolines” are contour lines, drawn around the outer surface of 
the TIN.  An isoline connects equal values of measurement on any continuous surface.  In this 
exercise, you are going to create isolines at a contour interval (C.I) = 10”, and then overlay 
those contours on the 3D TIN of rainfall.  This will give you a better understanding of how 
contour mapping allows you to represent 3 dimensions in 2D.  
 
 
            > 50” 
          45-50 
Cross-section of rainfall TIN  40-45 
             35-40 
                       30-35 
                   25-30 
                            20-25 
                        15-20 
                     10-15 
                                          5-10 
                0-5 
 
Procedure:  Re-open your Exr03_map in ArcMap (not ArcScene).  If you did not set your 
Document Properties > Save relative paths earlier, you may see a red exclamation point (!) to 
the left of the TIN in the ToC (see below); this indicates that you need to re-set the directory 
path to the source of your TIN. 

   
 Rt-click on the tin_* (* = your name) in the ToC > Properties > Source > Select Set Data 

Source (above right).  Scroll to the location of your TIN (below, left). 

.     
 Select your TIN (above left); the Layer Properties window re-appears (above right) 
 Press OK.   
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The Data View re-appears with the TIN visible. 
 Click on the drop-down arrow     on the 3D Analyst menu > Surface Analysis > Contour: 

   
 A Contour window appears (below left), 

   
Select the following parameters (above, right): 

o Input surface : tin_* (* = your name) 
o Contour Interval: 10 (1 line for every 10” of rain) 
o Base Contour: 0 (this will be the first, lowest contour line) 
o Z factor: 1 (a measure of vertical exaggeration) 
o Output features: Use the folder button         to set the directory path to your Exr03 

folder, and Save the contour map as rainfall_contours in your folder. 
o Press OK on the bottom of the Contour window (above, right) 

 The rainfall_contours shapefile should appear in your map window and in your ToC.  The 
default black lines should overlay the TIN at 10, 20, 30, 40, and 50”, at the breaks in color 
that correspond to each of those values: 
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 Rt-click on rainfall_contours > Properties > Labels tab ; Layer Properties appears: 

 
 Checkmark “Label Features in this layer”. 
 In the “Label field:” window, select Contour; you may also want to change the font to Bold 

using Symbol. 
 Click Apply (if you changed the font), then OK. 
The ArcMap Data View will return with 10, 20, 30, 40, and 50-in rainfall contours labeled: 

 
 Select File > Save 
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Step 9 - Open ArcScene, add rainfall contours to the 3D view 
Discussion: You will use ArcScene to look at the relationship between a TIN and Contour map. 
Procedure:  
 Re-open your Exr03_3D.sdx file.  
 Select File > Add Data, scroll to your Exr03 folder, and select rainfall_contours.shp: 

 
The contours are displayed in a flat plane, underlying the TIN.  You must instruct ArcMap to 
“drape” line features on top of the TIN. 
 Rt-click on rainfall_contours > Properties > Base Heights tab: 

   
 Under “Height:” select Obtain heights for layer from surface (red arrow above right).  Use 

the Browse button (Green arrow) to scroll to your tin_* (* = your name); press Add. 
 Leave the Z-init conversion at 1 (blue arrow above right). 
 Do not add an offset. 
 Click Apply, OK when the Layer Properties window returns. The contours “rise” into position 

at the breaks between colors (below left).  You may wish to change their color and thickness 
(see below right) by dbl-clicking on the contour line in the ToC and use Symbol Selector. 

   
 Select File > Save. 
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Step 10 - Evaluate the rainfall TIN and contours in 3D and 2D 
Discussion: Spend some time moving the TIN_* and rainfall_contours around in ArcScene. 

o Rotate the image to the cross-sectional view portrayed in the exercise instructions 
above, and make sure you see how the contours wrap around the outside of the TIN, 
connecting equal values together (all the 10s, 20s, 30s, 40s, and 50s). 

o Take the image to “map view” (as though you are directly overhead)) and note its 
similarity to ArcMap - now it is a 2D view.  Can you see how contours can represent 
3D images in 2D? 

Contouring is perhaps the most powerful quantitative mapping tool in existence.  Even non-
spatial thinkers, managers, and your bosses can see “highs”, be they for elevation, 
contamination, or number of crimes per day.  If you learn how to use this tool, your analytical 
capabilities will improve immensely, along with your abilities to share your analyses with others. 
 
Step 11 - Embed ArcMap and ArcScene views into your write up of this exercise. 
 Create a layout in ArcMap, at a scale of about 1:2,000,000; Export it as a jpg. 
 Create a view of ArcScene (it is not capable of creating layouts);Export it as a jpg. 
 Open MS Word and begin your exercise writeup.  During the course of your writeup, use 

Insert > Picture > From file and Insert both the ArcMap jpg and ArcScene jpg into your 
document. 

 In about 250 words, indicate: 
o what you learned about table joins, 3D viewing, and contouring 
o what you liked and disliked about the exercise 
o how you'd like to see this exercise changed in the future, if at all. 

 
Due Date:  Approximately two weeks from the date the exercise was assigned.  Consult your 
syllabus or WebCT calendar for the current semester. 


